SalesForce Integration Not Working

  • Profile Image
    clairenmarsh
    Asked on May 09, 2014 at 06:56 PM

    I completed the salesforce integration with Leads for my form titled "Organization Application Form", and mapped all fields, however after testing this information was still not pulled into a new lead on my Salesforce. Is there another step I must complete?

     

    Thanks!

    Claire

  • Profile Image
    Cesar
    Answered on May 10, 2014 at 12:12 AM

    Please try removing the integration and re-create it then re-map the field, if you have not yet done so. Make sure that the fields are properly mapped as SalesForce is very exact when it comes to mapped fields, so the same fields have to exists both on SalesForce and your form.

    Do let us know if you need further assistance. Thank you. 

  • Profile Image
    clairenmarsh
    Answered on May 10, 2014 at 10:53 AM

    Hi Cesar,

    I just tried removing and adding again - still nothing coming into our leads. I have made sure that the same exact fields exist in Salesforce and have mapped them out on our form. Maybe its an issue with the field type? i.e. Radio buttons exist on Jot Form, but not on Salesforce, so on Salesforce I have made that field a picklist. 

    Let me know if there is a number I could call to speak with someone about this over the phone. Thanks!

  • Profile Image
    jonathan
    Answered on May 10, 2014 at 09:14 PM

    Hi Claire,

    I have checked your form http://www.jotform.co/form/32796132162857 integration settings to SF and so far could not find the cause of problem yet.

    But since you have a lof of fields mapped on the form to SF, I am not sure which field could be preventing the integration from working properly

     

     

    May I suggest for initial troubleshooting we do it like this

    1. Clone your form http://www.jotform.co/form/32796132162857  to have another copy.

    Use this guide -How-to-clone-an-existing-form-from-your-account

    2. Use the clone version of the form

    3. Remove the SF integration on the clone form 

    4. Integrate the clone form to Salesforce

    5. BUT this time, map only as few fields as possible (try Names, Company, and E-mail fields only  in the mapping field

     

    6. Save the integration

    7. Test submit the form.

    Check if the integration work on this test.

    Please update us of the result.

    Thanks!

     

    ---

    Unfortunately, we do not have over-the-phone support, so, we are not able to call you.

     

     

  • Profile Image
    clairenmarsh
    Answered on May 12, 2014 at 12:28 PM

    Thank you for this! I have done what you suggested and found that the radio buttons were breaking the integration since I had them mapped to checkboxes on Salesforce. I changed the field to be a picklist and it is now working.