What is JotForm?
JotForm is a free online form builder which helps you create online forms without writing a single line of code. No sign-up required.

At JotForm, we want to make sure that you’re getting the online form builder help that you need. Our friendly customer support team is available 24/7.

We believe that if one user has a question, there could be more users who may have the same question. This is why many of our support forum threads are public and available to be searched and viewed. If you’d like help immediately, feel free to search for a similar question, or submit your question or concern.


  • Profile Image

    Edit link problems with IE8

    Asked by Neil Jones  on May 16, 2014 at 07:00 AM
    The form should open prepopulated with the data in the submission. This works with Chrome and Safari but not Internet Explorer. When opening in IE, the form opens without populating the details and it also shows all the fields despite them being condition controlled.
    Page URL:
    http://form.jotformpro.com/form/40493558915969

    email edit link all and
  • Profile Image

    Answered by Carina on May 16, 2014 at 10:39 AM

    I made some test submissions and could not replicate this:

    Can you please provide us more details, like an edit link or which auto-responder is creating this difficulties so we can run more tests. Also which IE version are you using?

    Thank you for helping us understanding this better.

  • Profile Image

    Answered by VCE on May 19, 2014 at 05:26 AM

    It is any of the emails sent that contains the edit function.

     

    The issue seems to be that IE8 is no longer supported. Every other browser works (I haven't tried a newer version of IE yet).

     

    Would you know of any reason IE8 no longer works?

  • Profile Image
    JotForm Support

    Answered by ashwin_d on May 19, 2014 at 06:52 AM

    Hello VCE,

    It seems you are right. I am able to replicate the exact same issue you are having. I cloned your form and configured the conditional emails to send submission emails to my email address.

    When I clicked the received edit link in chrome and IE9 it seems to work as expected. It loaded all the saved data but when I tested the same edit link in IE 8 developers tool, it did not populate any submission data.

    Though IE8 is an outdated browser but the edit link should still work. I am creating a bug report and sending it to our back end team. We will get back to you as soon as we have any update from them.

    For now I will suggest you to use chrome or IE9 to edit your submission records.

    Thank you!

  • Profile Image

    Answered by VCE on June 04, 2014 at 06:58 AM

    Hi,

    Do you have an update on the bug fix for IE8 please?

  • Profile Image

    Answered by jedcadorna on June 04, 2014 at 10:10 AM

    No updates yet from our level 2. You'll be notified in this thread if there's any update.

  • Profile Image

    Answered by cettox on June 06, 2014 at 07:30 AM

    Hi VCE, this bug is now fixed. Can you try again to see if it is fixed on your end?

  • Profile Image

    Answered by VCE on June 13, 2014 at 09:09 AM

    Hi,

    The form now opens prepopulated in IE8. however, it doesn't appear to remember conditions setup in the form so although a condition says "show other field when this field is populated" and the form opens with the field populated but the rest of the fields are not visible.

     

    It works fine in Chrome. 

  • Profile Image

    Answered by Carina on June 13, 2014 at 01:27 PM

    I tested some conditions (If change to Job role is equal to yes) and they were working in IExplorer when using the edit link:

     

    Can you please give more details on the condition(s) that are not working in IExplorer so we can test and detect the causes?

    Thank you

  • Profile Image

    Answered by VCE on June 16, 2014 at 05:17 AM

    The form I am having an issue with is http://form.jotformpro.com/form/41621830562954

    I complete the form, select an Agreement type (Blue), fill in all fields, submit it and when I click the edit button in the email and go to the Agreement Details section of the form, the Agreement type is visible and shows Blue as previously selected but no other fields show.

    However, if I change the the select to another Agreement type and then back to Blue, all the fields show again.

    As previously mentioned, if I paste the edit link into Chrome, it works fine.

  • Profile Image
    JotForm Support

    Answered by Welvin on June 16, 2014 at 09:54 AM

    Can you please check if the compatibility mode is active in your IE8 browser? That could be the reason why the conditional logic doesn't working. 

    http://windows.microsoft.com/en-PH/internet-explorer/use-compatibility-view#ie=ie-8

    Thanks

  • Profile Image

    Answered by VCE on June 16, 2014 at 09:57 AM

    Hi,

    Yes, compatibility view is active

     

  • Profile Image

    Answered by VCE on June 16, 2014 at 10:16 AM

    In fact, compatibility mode causes more issues when completing the form

  • Profile Image
    JotForm Support

    Answered by ashwin_d on June 16, 2014 at 01:02 PM

    Hello VCE,

    I am not sure if I understood your response well.

    Do you mean to say that you have issues when you have turned ON the compatibility mode? How about testing after turning OFF the compatibility mode of your IE browser?

    We will wait for your response.

    Thank you!

  • Profile Image

    Answered by VCE on June 18, 2014 at 05:10 AM

    Ok.

    Here are the issues I'm having. 

    I fill out the form mentioned above that contains conditions to show fields when other fields are populated. I receive an email with an "edit submission" link in it. When I click the link, the form opens in IE8. The trigger fields are populated but the conditional ones are not visible.

    If I change the selection in the field and then change it back the other fields appear. 

    If I resubmit the form without changing anything, the fields that haven't displayed do not show up in the email. 

    The latest issue is, if I open the form in IE8 and turn on compatibility mode, the form fields are unable to be entered - this isn't a big issue for me. I just won't turn on compatibility mode.

  • Profile Image
    JotForm Support

    Answered by ashwin_d on June 18, 2014 at 09:03 AM

    Hello VCE,

    I believe I have understood your issue now.

    It seems the form conditions are not being triggered automatically if the field already has correct value. I created a simple demo form with conditional fields and I am able to replicate the issue you are having.

    I am reporting this to our back end team. We will get back to you as soon as we have any update from them on this issue. 

    Since we cannot create multiple ticket in one thread, I have created a new thread for you and sent it to our back end team. 

    Thank you!