Our jotform not showing up for random users. What's the solution?

  • Profile Image
    AMP1887
    Asked on May 21, 2014 at 12:32 PM

    We're having problems with our jotform not showing up for random users, on random platforms and random browsers. Though Firefox on the Mac is the most common among the "randomness." Our website is built with Joomla.

  • Profile Image
    ashwin_d
    Answered on May 21, 2014 at 02:00 PM

    Hello AMP1887,

    I did check your web page where you have your form embedded and I am able to replicate in in chrome browser. It seems that you have the following css code in your Joomla website.

    script { display: none; }

    Since you have embedded your form using its script code, that is preventing the form from being displayed.

    Have you checked our guide on how to embed form in Joomla already. Please check the following guide :  http://www.jotform.com/help/246-How-to-Embed-Form-to-Joomla-3

    Please ensure that you follow this guide and then embed your form.

    Do get back to us if the issue persists.

    Thank you!

  • Profile Image
    AMP1887
    Answered on May 21, 2014 at 02:39 PM

    Thanks for responding.  We're on Joomla 2.5.6. It will not allow me to use the Sourcerer plug-in.We use the TinyMCE editor and cannot turn off clean-up code.  And are you saying that you cannot see the form on Chrome? I can see it on Chrome on my Mac and PC. Thanks.

  • Profile Image
    EltonCris
    Answered on May 21, 2014 at 03:45 PM

    @AMP1887

    Like my colleague, I am not also able to see the form on my browser. When I check the page source, I can't find any form embed code. Did you remove the form on your page? Please re-embed the form to your page using iframe embed code, this might resolve the problem. Guide: Getting-the-Form-iFrame-Code

    I think this guide uses Joomla 2.x. Kindly check this as well, maybe using jumi plugin will help. http://www.jotform.com/help/6-Adding-Form-to-Joomla

    Contact us again if you need further assistance. Regards!

  • Profile Image
    AMP1887
    Answered on May 21, 2014 at 03:57 PM

    I tried the iframe code. That still didn't work with Firefox on the Mac.  So, I've added a note in the side bar with the direct link. This does work on Firefox on the Mac.  And I'm assuming if a user is on Chrome, Safari or IE on any platform, it will also work. It's not the most elegant solution, but I think it should be sufficient. I'll continue to troubleshoot Joomla, though. Thanks.

  • Profile Image
    Jeanette
    Answered on May 21, 2014 at 04:34 PM

    Glad to see you sorted out the problem somehow. Do let us know about your findings, probably we ought to update that Joomla guide.

    Kind regards.