What is JotForm?
JotForm is a free online form builder which helps you create online forms without writing a single line of code. No sign-up required.

At JotForm, we want to make sure that you’re getting the online form builder help that you need. Our friendly customer support team is available 24/7.

We believe that if one user has a question, there could be more users who may have the same question. This is why many of our support forum threads are public and available to be searched and viewed. If you’d like help immediately, feel free to search for a similar question, or submit your question or concern.


  • Profile Image

    Form conditions not working with Chrome and Windows 8?

    Asked by Aaardvaark on May 22, 2014 at 09:00 PM

    A Windows 8 user has reported that my form is not working for him, though seems ok for others. I've tested it ok with Chrome and Firefox on Win7 and also on iPad.  I can't get it to work on ANdroid for other reason. Form address is below.

    The form is supposed to open with a 'set location' widget visible. There is a radio button to select between using the widget/map to set location or entering your own coordinates - this is preselected to use the map.  So if the radio button says 'use map' then the map widget should be visible and the the manual lat/long boxes should be hidden, and vice versa if "I will enter lat/lb=ongs directly' is used.

    His problem (see screenshot) is that the form opens up with the 'use map' radio button preselected as it should be, but:

    a) the manual lat/long boxes are visible,

    b) the map question is visible but the map itself does not appear.

    Can you tell me what the issue might be and how to fix it?

    Page URL:
    http://canberrabirds.org.au/incidental-record-form/

    Screenshot
    and problem ipad hidden Android
  • Profile Image
    JotForm Support

    Answered by BDAVID on May 22, 2014 at 10:49 PM

    Could you let us know what problem you are seeing in your form when viewed in android device?  I am using Windows 8, and I check your form in Chrome(Version 34.0.1847.137 m), but the problem did not replicate: 

    Also, I checked your conditions, and they seem to be very well set up, is this only happening to one user? Could you ask him what version of Google Chrome he is using? Also, clearing browser's cache might help. 

  • Profile Image

    Answered by Aaardvaark on May 23, 2014 at 05:06 AM

    Thanks.

    1. Yes the map problem is only happening to one person, but he is important and has recent Win 8.1.  He hasn't responded yet with version of Chrome, but I assume it is recent.

    2. The problem on my android phone is that the date and time boxes don't work.  They have simple validation checking for numbers and including the slashes.  First number or two is ok but then you can't enter anything else, maybe after trying to enter an alpha instead of number by mistake?  I can't backspace erase even when the cursor is next to a number, and I can't enter anything new.

     

    There is a real need for date /time entry with non-US format, and for real date and time validation that excludes days >31, months >12 etc.

  • Profile Image

    Answered by jedcadorna on May 23, 2014 at 07:48 AM

    Hello,

    I just tested this on Android tablet with chrome version 35 and works fine. Are you referring to the validation when you put a value in 'yy' it does accept more than 12 and in 'dd' it does accept more than 31? It does only accept numbers though, letters and not being accepted. Can you please confirm this before we raise a ticket to our back end team.

    When backspacing or erasing the value you have to click on the next slash then erase the value same this goes with 'time' field you have to go to ':' then erase the character. It does not automatically start erasing from the end.

  • Profile Image

    Answered by Aaardvaark on May 24, 2014 at 02:34 AM

    Two issues are being mixed here.

     

    1) THe original main issue, the person who can't see the map.  He advises he is using Win 8.1. and

    Chrome Version 35.0.1916.114.  He still can't see the map as per original screenshot.

     

    2)

    Not able to use the date time boxes on some android devices.  It works fine on my ver 4.4. tablet, it doesn't work at all on my Galaxy s2 phone.  As mentioned, and possibly only after trying to enter an alpha character, it locks so you can't enter anything or backspace to delete.  Probably it's not getting focus right.  This is only on my phone which is older Android.

  • Profile Image
    JotForm Support

    Answered by jonathan on May 24, 2014 at 07:49 AM

    Hi,

    To properly provide you the assistance, I have split the question on this thread. I have created a separate new post for the "Android" device issue here

    https://www.jotform.com/answers/382696

    We will respond to you separately on that post.

    --

    As for the original question about this thread, I also checked your form in your website http://canberrabirds.org.au/incidental-record-form/  using Windows 81. and Chrome v35 browser -- but I was not able to reproduce the issue reported. I was able to view the map and interact with the form (please see screenshot below)

    (click on image to enlarge)

     

    I understand that this issue can be varying in consistency as each system may have different configurations (due to differences in OS and other components installed on a computer system)

    But we would like to find out a consistent pattern at least so that we can narrow down the combinations why it will not work on certain system configuration.

    You mentioned that there were at least more than one users that have encountered similar glitch. It would greatly help if you can find out what system configuration they have also.

    If OK to suggest, you can find out more about a user's system details via the form submission email.

    Please check this guide on how to do it -How-to-Catch-User-s-Browser-Info

    You can add the notification email as described on the guide, then you will be able to find out what the user have on their end. 

    Hope this help. Please continue updating us, more so if the issue become consistent and can be reproduce at will. We will make sure to attend to you at once.

     

    Thanks!

     

     

     

     

  • Profile Image

    Answered by Aaardvaark on May 25, 2014 at 04:34 AM

    Thanks.  I can't contact the guy with the problem for a few days.  THis problem only occured with one person.

     

    But there might be a clue here - in an answer to my other question, the help person set up an Android emuation of my page to demonstrate something.  But I noticed that on my computer this emulation works fine EXCEPT it won't show the map, the same problem as originally notified. Is this a help?  I tried refreshing etc but no change.

     

  • Profile Image
    JotForm Support

    Answered by jonathan on May 25, 2014 at 02:43 PM

    Hi,

     the help person set up an Android emuation of my page to demonstrate something.

    Can you please clarify what you meant by this? Did it meant browsing your website in an Android device?

    I did a test again of your website  using Android browser, and I was still able to view the form and map on it

     

    Please describe to us the steps you've taken during your testing the reproduce the issue, and we will try to follow it and check if we can replicate.

    Update us if issue persist.

    Thank you.

  • Profile Image

    Answered by Aaardvaark on May 26, 2014 at 03:23 AM

    The issue persists, the guy who originally had the problem with my form still has the problem.

     

    I was just pointing out that if I try to use this version of the form https://secure.jotformpro.com/form/41418303127950 I have the same problem - no map.  So that's two examples.  (This version was set up by your people) see http://www.jotform.com/answers/382696-Not-able-to-use-the-date-time-boxes-on-some-android-devices?entrymessage=10732640770 in message "Answered by BDAVID on May 24, 2014 at 12:12 PM"

  • Profile Image
    JotForm Support

    Answered by jonathan on May 26, 2014 at 08:02 AM

    Hi,

    Can the person having issue also try using other browser? Perhaps they can try using Firefox and check if the issue also happen.

    I am sorry, we could not reproduced the issue on our end, so we could not really relay anything to our higher team support.

    Thanks.

  • Profile Image

    Answered by Aaardvaark on May 26, 2014 at 07:19 PM

    Hi

     

    Are you saying that when you look at https://secure.jotformpro.com/form/41418303127950 you can see the map?

    Because when I go to that page I can't see the map in Chrome, Firefox or Internet Explorer.  Is this page (an emulation) supposed to show the map?

  • Profile Image
    JotForm Support

    Answered by jonathan on May 26, 2014 at 09:10 PM

    I apologize for the confusion.

    But Yes, what I meant, was I was still able to see the "map" in the form even when I did the test using Android browser emulation on your website http://canberrabirds.org.au/incidental-record-form/

    as you can see on the screenshot above, I was browsing your website and the embedded form. The map field is available on the embedded form and I can interact with it.

    To further clarify, I understand that the original issue you reported here was the form in your website was not working when using Windows 8.1 and Chrome browser. We have been doing that test so far, and still not able to duplicate the reported issue during our testing.

     

    Thanks.

     

     

  • Profile Image

    Answered by Aaardvaark on May 27, 2014 at 12:29 AM

    OK thanks.  The original problem was with one person only, and I can't get more info for a while from him so we should let that go for now.

     

    BUT -  why can 't I see the map when I go to https://secure.jotformpro.com/form/41418303127950  ?

    I can see it when I go to http://canberrabirds.org.au/incidental-record-form/