Why aren't my forms updating?

  • Profile Image
    theflyerguys
    Asked on August 15, 2011 at 12:09 PM

    I have edited my form some time ago. When I visit the form page, it shows all of the correct form updates. The problem comes when a client actually places an order and has to complete the form, it shows the oldest form from when I feirst created the account. I have since went to the page where the form is embeded and pasted the code again (it was exactly the same code). Any knowledge as to how its populating the form without any revisions? I've provided a link to the form with correct edits, as well as the form response sent to me via email... They are totally different.

  • Profile Image
    yasinco
    Answered on August 15, 2011 at 12:56 PM

    Make Sure You Saved The Edit And Refresh The Page. If That Does Not Work Click "Embed Form" And Then Click On "Iframe" Then Use That Code.

    Hope This Helps

  • Profile Image
    brx250
    Answered on August 15, 2011 at 10:24 PM

    Hi there,

    I've tried replicating your issue on our end and I've seen some inconsistencies with your email notification. After editing your form, you might have forgotten to alter your notification's content too. I suggest you review it together with your form's fields, and do the necessary changes. I've attached a link of the screenshot that shows some of the irregularities.

    http://i1126.photobucket.com/albums/l618/jotformtech/notinotequalform.jpg

    In addition, I strongly suggest you use iFrame instead of the full source code. Aside from being more stable than any other embedding methods, it also updates itself automatically for any changes made in JotForm, thus saves your time and effort. Hope this helps.

    If you have further issues and concerns, please feel free to contact us anytime.

    Thank you for using JotForm.

    _____________________________________________ 

    Albert  JotForm Support

     

  • Profile Image
    theflyerguys
    Answered on August 15, 2011 at 10:34 PM

    Thanks for the speedy reply. I was unaware about having to update the notification. That was the problem. They are seeing the correct form, but I wasn't receiving the correct notification. I have since deleted the notification and recreated it with the new fields. 

     

    Thanks so much!

  • Profile Image
    abajan
    Answered on August 15, 2011 at 11:09 PM

    Hi theflyguys

    Glad my colleague Albert was able to rectify the problem for you. It's perhaps worth noting that regardless of the configuration of notifications, the submissions page will show the updated version of the form.


    ~ Wayne

  • Profile Image
    theflyerguys
    Answered on August 15, 2011 at 11:14 PM

    Yes I understand... The page was displaying correctly the entire time. It was the emails that were displaying old content since I never updated the notification email. The visitors were submitting the correct info - I wasn't fetching the correct info.

  • Profile Image
    abajan
    Answered on August 15, 2011 at 11:21 PM

    No, I meant the page where the submissions are stored (that is accessed via the Submissions button on the "My Forms" page), not the page where the form is displayed to visitors.

    ~ Wayne