Picture attached to email notification questions

  • Profile Image
    traketo
    Asked on July 01, 2014 at 11:40 AM

    i have tried every possible solution but for some reason no pictures will send, i can provide my html if needed to see if you can find what i have done wrong the form in question is sales order form 2.0

     

     

    thank you

  • Profile Image
    EltonCris
    Answered on July 01, 2014 at 12:02 PM

    Hi,

    When I check your order form 2.0, I see no notification in it. Just create a new notification for that form, that should resolve the problem.

    Just a friendly note, when you're embedding the form using source code, make sure not to change or modify any of the field names otherwise the form will not be able to capture the data entered on the fields.

    Thanks!

  • Profile Image
    traketo
    Answered on July 01, 2014 at 12:44 PM

    i did set up a notifier and still the pictures wont come through.

  • Profile Image
    EltonCris
    Answered on July 01, 2014 at 12:48 PM

    Hi,

    Did you embed the form to your website? If so, may we know the website URL so we can check the form here.

    Your stand alone form is working fine so I suspect the modified embed code is the culprit. Please provide the HTML code you mentioned so we can review the form.

    We'll await your updates. Thanks!

  • Profile Image
    traketo
    Answered on July 02, 2014 at 03:52 PM

    i believe my answer to the request is being deleted. i have posted a link to it twice and i check on it and cant see my answer...

  • Profile Image
    david
    Answered on July 02, 2014 at 05:45 PM

    Hi,

    As my colleague stated it would be very helpful for us to be able to see the page your form is embedded into.  You are unable to post a link in our forum?  I am not sure why this might be, you can try pasting the link without the www. and the .com if something is possible blocking you from posting links.  Please let us know and we will be happy to look into your issue further.

    Thank you for using Jotform!

  • Profile Image
    traketo
    Answered on July 03, 2014 at 08:42 AM

    drive.google.com/file/d/0B5WlxhVM8fPBdWI5Y0hPVHN3MGs/edit?usp=sharing

     

     

    i have posted this link several times and it somehow gets deleted, that is the download link to the html where the from is embedded.

     

    if it happens again is there anyway to post the html ?

     

    thank you

  • Profile Image
    KadeJM
    Answered on July 03, 2014 at 10:36 AM

    Thank You for re-sharing that link with us. If it got deleted beforehand then it sounds like it wasn't accepted correctly when you shared it. Either way though, we do apologize about that inconvenience.

    Upon investigating this more via some tests I found that your setup is correct and that it is working correctly by itself. So I think what is happening here is that you have most likely modified something when using the embedded code or something got left out.

    I can verify there is that problem because it works by itself through a separate test - see below:

     

    However, On your form this did not come through and got left behind including other data:

     

    It turns out that your embedded html for your form submit script is missing a tag that is required for your data to submit correctly with included files.

     

    You have:

    <form class="jotform-form" action="http://submit.jotform.us/submit/41813396640961/" method="post" name="form_41813396640961" id="41813396640961" accept-charset="utf-8">

     

    It should be:

    <form class="jotform-form" action="http://submit.jotform.us/submit/41813396640961/" method="post" enctype="multipart/form-data" name="form_41813396640961" id="41813396640961" accept-charset="utf-8">

     

    You are missing:

    enctype="multipart/form-data"

    Please see this detailed explanation about this to learn more in-depth about why it is important

     

  • Profile Image
    traketo
    Answered on July 03, 2014 at 11:29 AM

    Thank you Kade that suggestion did allow it to show up when i looked at submissions online, is there anyway to make the picture file show up in the notification email rather it be an attachment or in the actual body of the email? thank you very much. that last bit was definitely a step forward in what i am attempting to accomplish.

     

  • Profile Image
    EltonCris
    Answered on July 03, 2014 at 12:04 PM

    @ traketo 

    That's great to hear. On behalf of my colleagues, you're welcome!

    If you want it to appear as image on email, simply insert IMG on the image field tag on your form notification.

    Example:

    {IMG:uploadimage}

    Or you can click the image field tag the one with blue exclamation icon on the form fields sidebar found on the notification wizard.

    Example:

    Hope this helps!