required fields aren't working