Facebook code changes label colour in FBML

  • Profile Image
    DroppedPin
    Asked on July 22, 2010 at 03:31 AM

    Hi

     

    I've set up my form but the label colour remains a dark grey in FBML. The same form shows the right colour in my iweb but in Facebook it won't show the right colour. Please help.

  • Profile Image
    aytekin
    Answered on July 22, 2010 at 06:29 AM

    Please look at the example form on Facebook page on the "Step 6" of this page:

    http://www.jotform.com/help/22-Adding-Form-to-Facebook

    Is that what you mean by "gray" or do you get something else?

  • Profile Image
    DroppedPin
    Answered on July 22, 2010 at 06:33 AM

    Yes that right. My form is here if You'd like to be sure. http://www.facebook.com/DroppedPin?v=app_10442206389

     

    Also my website with the right colour has the form here: http://droppedpin.net/Dropped_Pin/Order_Form.html

     

    EDIT: Fixed the broken link!

  • Profile Image
    aytekin
    Answered on July 22, 2010 at 07:29 AM

    The first link does not work. I get a "Not Found" error. 

  • Profile Image
    DroppedPin
    Answered on July 22, 2010 at 07:32 AM
  • Profile Image
    DroppedPin
    Answered on July 22, 2010 at 07:33 AM

    Also the required fields don't actually work..I'm able to submit a blank form..Is this related to conditions not working in FBML?

  • Profile Image
    aytekin
    Answered on July 22, 2010 at 08:04 AM

    I see what you mean. I am not sure why that is happening. Can you try putting <font color="yellow"> around those labels?

    Yes, unfortunately, validation(required fields) and conditions do not work on Facebook pages. 

  • Profile Image
    DroppedPin
    Answered on July 22, 2010 at 08:23 AM

    Yes that seems to work!! Thanks so much... :-)

  • Profile Image
    DroppedPin
    Answered on July 22, 2010 at 08:29 AM

    Another query..I had previously added the star rating field in the form but removed it as on applying it on FBML, the stars would turn into a drop down field with values 1 - 5. Any fix for it?

  • Profile Image
    aytekin
    Answered on November 01, 2010 at 09:01 AM