Appointment Slot: Showing field is required when when a time is selected

  • Profile Image
    mgrott
    Asked on June 30, 2022 at 12:24 PM

    I am creating a Jotform for testing appointments and am having an issue with users not able to choose dates for three of our locations. The first location works OK, but if they choose any of the others the error is that is it a required field.


    https://form.jotform.com/221727714760154



  • Profile Image
    Sheena
    Answered on June 30, 2022 at 02:11 PM

    Hello there,

    I tried to replicate the issue on my end however I am unable to do so. Please see the screencast of my result:

    1656612435_62bde653eefb7_

    Sometimes this kind of issue is temporary and it resolves itself. I have cleared your form caches to refresh your forms. If the issue still persists, could you please share a recording showing the steps you are taking to reproduce the issue at your end so that we can assist you further accordingly? You may use Vidyard to record your screen and then share the recording link here in this thread.

    Keep us updated and let us if you need any other help.

  • Profile Image
    mgrott
    Answered on June 30, 2022 at 04:22 PM

    I am still having an error. Let me know if this recording worked.


    https://share.vidyard.com/watch/HKrZBF5wKEExNtDTnwnCfX?

  • Profile Image
    Mary
    Answered on June 30, 2022 at 09:37 PM

    Hello mgrott,

    Thanks for providing us with a screen recording. I followed the steps down on your recording but did not encounter the same issue:

    1656639345_62be4f716574e_GIF1.gif

    I have cleared your form cache, could you try making another test submission? If the issue persists, please allow us to make a test submission on your form.

    Give it a try and let us know how it goes.


  • Profile Image
    mgrott
    Answered on July 04, 2022 at 10:25 PM
    We are still having issues with this form. I have tried multiple computers
    and am still receiving the same error. Tomorrow I will try to recreate the
    form from scratch with the hope this will fix the problem. Are there any
    other suggestions?
    Thank you,
    ...
  • Profile Image
    Harvey
    Answered on July 04, 2022 at 10:44 PM

    Hi mgrott,

    Thanks for getting back to us. I've cloned your form for checking and when I tested your form and made a submission, the same thing happened, I cannot submit the form after selecting one appointment field so I created a ticket about it and escalated this to our Developer team. Once we hear back from them, we’ll update this thread and let you know.

    We really appreciate your patience and understanding.