I am using Authorize.Net as my payment gateway and the form will not submit because it is saying zip code required even if you have a zip code entered

  • Profile Image
    HammondSummer
    Asked on September 02, 2014 at 12:04 PM

    We had this issue in regular mode so I switched over to sandbox mode and still a problem.

  • Profile Image
    Welvin
    Answered on September 02, 2014 at 12:37 PM

    Hi,

    Do you have a screenshot of the error? What is the ZIP Code you provide?  I have tested your form and it went through without any errors on submit. Here's a screenshot:

    Can you please try again? Update us here if the issue persists.

    Thank you!

  • Profile Image
    HammondSummer
    Answered on September 02, 2014 at 12:52 PM

  • Profile Image
    HammondSummer
    Answered on September 02, 2014 at 12:57 PM

    This happened when we were not in Sandbox mode so that is why I switched us over to test.  What am I doing wrong.

  • Profile Image
    Kiran
    Answered on September 02, 2014 at 01:41 PM

    I was able to submit the form using the test credit card number without any issues.

    As I see your screenshot, I observe that the security code and Street Address Line 2 are blank. You may try again to submit the form by filling all the fields in the payment information. You may use any 3 digit number as a security code while using test credit card number.

    Please get back to us if you need further assistance. We are happy to assist you.

     

  • Profile Image
    HammondSummer
    Answered on September 02, 2014 at 01:49 PM

    It worked this time,  why is the address line 2 required?  Can I change this.

  • Profile Image
    Kiran
    Answered on September 02, 2014 at 01:54 PM

    We are happy to see that the issue is resolved for you.

    All the fields in the payment integration are mandatory and unfortunately it is not possible to change these mandatory settings at the moment.

    Please do not hesitate to reply to this post if you need further assistance. Thank you!!