Calculation Loop Problem: This form ID 41824131406344 loads slow when viewed in firefox and mobile device.

  • Profile Image
    hilltopkennels
    Asked on September 05, 2014 at 09:04 AM

    Form works well on desktop and tablets but very poorly on smartphones

  • Profile Image
    hilltopkennels
    Answered on September 05, 2014 at 09:21 AM

    I should also mention the form is embedded here (into an iframe) http://www.hilltopkennels.co.uk/#!Booking Request/c1dt4 

  • Profile Image
    jedcadorna
    Answered on September 05, 2014 at 12:15 PM

    Are you referring to the form load performance when viewed in mobile devices? Can you please try cloning your form and check if it loads same after cloned?

    You can see in my sample gif that it loads slow:

  • Profile Image
    hilltopkennels
    Answered on September 05, 2014 at 12:18 PM

    I mean when clicking on say a calendar date picker, there will be a long delay before it pops up to allow the date to be picked.

    I'll try cloning the form to see if it improves performance

  • Profile Image
    jedcadorna
    Answered on September 05, 2014 at 01:42 PM

    The problem is in your conditions, I tried disabling them all and it seems to load fast unlike when your conditions are enabled. Also I noticed that you have added £ pound symbol which might be the cause of the delay when form loads.

    Also I found values in your conditions like this "0.05". Try changing that to 0.05. All of this unwanted characters might adds up to the loading time.

  • Profile Image
    hilltopkennels
    Answered on September 05, 2014 at 04:03 PM

    The cloned form is slightly quicker.

    I can understand why the form would be quicker if I remove all the conditions but then it doesnt do what I need it to do. (That's a daft suggestion surely?) If I follow that tactic perhaps I should replace my form with a simple drawn blue rectangle, that would load REALLY fast! Though then it wouldn't be achieving much.

    The reason for referring to the discount field as text "0.05" is that it doesn't work if I test for 0.05 (the numerical equivalent)

  • Profile Image
    jedcadorna
    Answered on September 05, 2014 at 06:40 PM

    The latency might be caused by some of the libraries that Jotform loads. I checked the console using chrome and it shows some error.

    Let me forward this to our 2nd level so they can take a look into this.