Disabled form is not displaying the warning message when form is embedded

  • Profile Image
    inspireworks
    Asked on September 23, 2014 at 02:57 PM

    Hi Is it possible to disable your form but leave a message like "Thank you at this time registration is currently closed" on the page then have that go away once the form is enabled again. Thank you.

  • Profile Image
    Welvin
    Answered on September 23, 2014 at 04:33 PM

    Hi,

    Yes, that is possible. Please check this guide: https://www.jotform.com/help/180-How-to-Change-the-Status-of-Forms.

    In the Form Limits tab, change the message there:

    Thank you!

  • Profile Image
    inspireworks
    Answered on September 23, 2014 at 04:38 PM

    It doesnt appear that a mesage is put up when my form is inactive.

     

    http://www.inspireworksenrichment.com/AgawamRegistration.htm

     

    If I enable the form I can see the form, but when it is disabled I only get a blank page.

  • Profile Image
    Mike_T
    Answered on September 23, 2014 at 05:49 PM

    Please replace your jotform Embed code with an iFrame version. It will display the form warning on your web page.

    Please give it a try and let us know if you need any further assistance.

  • Profile Image
    inspireworks
    Answered on September 23, 2014 at 07:46 PM

    using iframe puts an ugly grey box on my page and the disabled message is shown very far down on the page.  Is there another way that I can keep the regular embed code and have the disabled message show up?

  • Profile Image
    EltonCris
    Answered on September 24, 2014 at 02:14 AM

    @inspireworks

    Thanks for your reply.

    I was able to reproduce the problem when I tried embedded a disabled form on a clean HTML page. https://shots.jotform.com/elton/disabled_form_test.html

    It is displaying this error on the browser console log so I think this is considered a bug.

    I have now forwarded this to our developers for further investigation. Once this is fixed, we'll update you via this thread.

    Thank you!

  • Profile Image
    sammamish
    Answered on November 03, 2015 at 12:41 PM

    I am also having that trouble with the embedded code, is there an update?
  • Profile Image
    kubinyi
    Answered on May 31, 2017 at 12:32 AM

    So now it's 2017 and it seems that this is still an issue. 

  • Profile Image
    jonathan
    Answered on May 31, 2017 at 01:49 AM

    @kubinyi

    Please create your thread about the issue you have on this feature so we can better assist you.

    You an use this link https://www.jotform.com/contact/

    Provide us much details as you can and we will take a look.

    Thank you.