What is JotForm?
JotForm is a free online form builder which helps you create online forms without writing a single line of code. No sign-up required.

At JotForm, we want to make sure that you’re getting the online form builder help that you need. Our friendly customer support team is available 24/7.

We believe that if one user has a question, there could be more users who may have the same question. This is why many of our support forum threads are public and available to be searched and viewed. If you’d like help immediately, feel free to search for a similar question, or submit your question or concern.


  • Profile Image

    Email notification not displaying all fields

    Asked by Kevin Reinhardt on October 23, 2014 at 03:31 PM

    The last 2 populated fields are not showing up in my notification emails.

    Attached is the end of my Notifications setup and you can see the last 2 questions.

    Neither of them are showing up.

     

    Also, at the end of my Storage Matrix, instead of leaving blank fields blank, it started to put dashes in them.  I can send you the email Notification that I received if that helps you any.

    Page URL:
    http://www.midwestmoving.com/contact-us/request-a-quote/

    Screenshot
    Emails email notification attached and
  • Profile Image

    Answered by Carina on October 23, 2014 at 05:48 PM

    I inspected your email notification and it seems it was customized. Although it is allowed, the email notification stops updating automatically if the form is edited:

    This means that, if after customizing the notification, you add or remove fields from the form, they will not be part of the notification. For that it is necessary to create a new notification or add manually the fields by clicking on them (on the right-side of the notification, as seen above).

    Let us know if we can assist you further.

  • Profile Image

    Answered by kreinhardt on October 24, 2014 at 09:21 AM
    I removed both the Notification and the Auto Responder and started fresh and I still have the same exact problem.
    I will forward you the email that I am receiving.
    Also, when I run a Test email, both the Notification and Auto Responder work.
    Thank you,
    Kevin
    ________________________________
    ...
  • Profile Image

    Answered by kreinhardt on October 24, 2014 at 09:21 AM
    This is the Auto Responder, that it cutting off the last 2 or 3 questions. It does the same on the Notifier.
    Thank you,
    Kevin
    ________________________________
    ...
  • Profile Image

    Answered by kreinhardt on October 24, 2014 at 09:21 AM
    Here is the Test Auto Responder. As you can see, the last 2 questions appear with no problem.
    ________________________________
    ...
  • Profile Image

    Answered by Carina on October 24, 2014 at 12:36 PM

    Which are the fields that are missing? I inspected your form and you have the "Hide empty fields on email" option enabled:

    Maybe is this that is preventing the fields from displaying in the notification and auto-responder.

    Unfortunately our support forum does not accept attachments. Please send your documents to our email support@jotform.com and add the thread number to the subject so we can easily identify the thread.

    Thank you

  • Profile Image

    Answered by kreinhardt on October 24, 2014 at 01:31 PM
    I just ran a test form and filled in all of the fields, including the last 2 questions on the form. Once again, the last two questions did not appear in either the Notification or the Auto Responder.
    You can run a test of your own if you would like. Just label it as a test and we'll no it isn't a customer.
    Thank you,
    Kevin
    ________________________________
    ...
  • Profile Image
    JotForm Support Manager

    Answered by Jeanette on October 24, 2014 at 04:15 PM

    You are right, it looks like the large matrixes and any field after those won't show even on a default autoresponder I made for testing purposes from your account.

    Let me make a clone and make some other tests in order to find out if this is a glitch or a mis-configuration.

     

     

     

  • Profile Image

    Answered by kreinhardt on October 24, 2014 at 04:21 PM
    Great, thank you for your follow thru.
    Thank you,
    Kevin Reinhardt
    ...
  • Profile Image

    Answered by kreinhardt on October 28, 2014 at 09:11 AM
    It's been a couple of days...what did your testing find?
    What is the game plan?
    Thank you,
    Kevin
    ________________________________
    ...
  • Profile Image
    JotForm Support

    Answered by Charlie on October 28, 2014 at 09:53 AM

    Hi Kevin,

    Unfortunately, we don't have an update for you right now. But rest assure that our developers and technical team have been informed about the bug and are already trying to solve the problem. My apologies for the delay, but you will surely receive a notification when an update has been made.

    Regards.

  • Profile Image

    Answered by kreinhardt on October 28, 2014 at 10:01 AM
    Great, thank you for that update. Please keep me in the loop.
    ________________________________
    ...
  • Profile Image

    Answered by kreinhardt on November 21, 2014 at 12:11 PM
    JotForm,
    Should I assume that there is no update on this yet? This is really hurting our form and we need to move on otherwise.
    Thank you,
    Kevin
    ________________________________
    ...
  • Profile Image

    Answered by Carina on November 21, 2014 at 01:40 PM

    Please accept our apologies for the time this situation is taking to get solved.

     

    This ticket has a "very important" priority level assigned but for now we still don't have an update. Unfortunately it is necessary to wait for more details from the developers.
    In the meanwhile I will make further tests to see if I can find a workaround for this situation.

    Let us know if we can assist you further.