JotForm Servers sending Spam

  • Profile Image
    retfar4
    Asked on September 19, 2011 at 06:01 PM

    I have been working with our IT guys over here to get JOTForms up and running... Unfortunately, the IT guys wont allow the site for the reason below:

    "I have allowed the send noreply@jotform.com, but since this is getting blocked because they are using a sending service thta started sending spam on 9/16, a sender allow may not work because typically servers known to send spam are blocked before the sending address can even be provided and checked." 

    Is there something we can do?

    http://form.jotform.com/retfar4/12560950770

     

  • Profile Image
    aytekin
    Answered on September 19, 2011 at 06:37 PM

    We are temporarily using a 3rd party service. I think they mean that. Not our servers.

  • Profile Image
    retfar4
    Answered on September 19, 2011 at 09:41 PM

    When will you no longer be using 3rd party servers?  We are trying to get this to work... I work in education where this could have some tremendous uses for administrators.  If we can get this to work at our site, we will likely use it throughout our district.  

  • Profile Image
    aytekin
    Answered on September 20, 2011 at 06:42 AM

    We will continue making changes this week. So, after next week it should be more stable. So, we recommend using gmail this week. 

  • Profile Image
    retfar4
    Answered on September 20, 2011 at 10:28 PM

    Will you be using servers that are not blacklisted for sending spam?  Apparently thats a problem for our IT guys over here...

  • Profile Image
    aytekin
    Answered on September 21, 2011 at 09:05 AM

    The reverse DNS is now fixed. If the emails were going to spam folder because of that, you should receive them from now on. 

  • Profile Image
    aytekin
    Answered on September 21, 2011 at 09:06 AM

    Blacklisted IPs were probably from the 3rd party email sending service we used temporarily. 

  • Profile Image
    retfar4
    Answered on September 23, 2011 at 01:19 PM

    I'm still haveing problems sending and receiving the forms.  We need to send email to TUSD addresses because we are sending them to teacher email inboxs through outlook.  For some reason the emails are not getting there.  JotForm has been whitelisted, but form some reason it's not working.  Any thoughts?  Are you guys still on 3rd party servers?  What servers are you sending from?  Would sending form SSL imrpove things?

  • Profile Image
    aytekin
    Answered on September 26, 2011 at 06:29 AM

    No, we are now using our own servers. 

    I made a test submission and the emails were not sent because of your conditions. 

  • Profile Image
    retfar4
    Answered on September 26, 2011 at 10:14 PM

    The form should only be submitted when the appropriate teacher is selected and when the appropriate administrator is selected.  If "Marzilli" is selected as the administrator and "Rafter" is the teacher the form should go to each address and not to any other.  It has worked on a few occasions and I know another site using it in a similar fashion.  I also have the forms being sent to a separate gmail account and those go through on a regular basis (scroll to the bottom of the conditions).  Can you tell me if there is an error in my conditions?  Is there any chance you have a contact number?  Our district IT guy was at our site today looking at it, this could be something that we use district wide if we get it working.

    Also, is there a way to embed the form in a website and use the websites servers to send the form?  If our network is blacklisting your servers is there a potential work around?

  • Profile Image
    retfar4
    Answered on September 27, 2011 at 10:12 PM

    Our district IT person posted this earlier:

     

    Can you do a manual test of email to:

    jpowell@tustin.k12.ca.us

    and send the information from your logs to:

    jeremynmipowell@gmail.com

     

    When we use the "tustin.k12.ca.us" domain as the destination, we never even see a tcp connection from monk, ying, or yang at our spam filter.

     

  • Profile Image
    mliz
    Answered on September 28, 2011 at 04:38 PM

    Hi retfar4,

    Moments ago I just made a form test and sent out the notification to the email address specified. You can find the mail log results posted in the separate thread opened. To keep it in one place please post your comments there so that you are kept in the loop with the status.

    Cheers!