Getting an error 522 when my form is viewed from a specific network

  • Profile Image
    AmirGol
    Asked on November 25, 2014 at 05:49 PM

    Hello!

    I'm using Jotform on a website running Wordpress. Regardless, on a certain network (in a university) the form is refusing to load and comes back with error 522. I have tried to replicate the issue myself on many different networks and it all works. It's only in this specific network (I'm assuming) that the problem is apparent, as I tested myself. I have read through several threads like this but found no answers on how to fix it. 

    Any help or suggestions on what could be causing this?

  • Profile Image
    raul
    Answered on November 25, 2014 at 08:04 PM

    Upon checking your website, I was able to load the form correctly.

    Error 522 is a CloudFlare error and you can see more details about it here: https://support.cloudflare.com/hc/en-us/articles/200171906-Error-522

    Since this only happens in a certain network, I think that it could be related to a firewall or proxy setting in this network.

    Have you tried to load the form using its direct URL: http://www.jotformeu.com/form/41403254505343 and see if the form refuses to load too?
    Also, you can try to do a traceroute as suggested on the cloudfare link to see if something is blocking the form from being loaded correctly.

    Let us know if you need further assistance.
    Thanks.