Form conditions not working properly

  • Profile Image
    SamanthaMackenzie
    Asked on December 03, 2014 at 12:53 PM

    I can confirm the same issue. 

    A "hide multiple" rule doesn't work.

    I have cleared the cache

    I have deleted the condition and recreated it

    I have even disabled another condition that also hid some of the same fields.

    This appears to be a bug.

  • Profile Image
    SamanthaMackenzie
    Answered on December 03, 2014 at 03:55 PM

    update:  I have solved the problem.

    The condition had some sort of corruption in it.

    Solved by:

    deleting the condition

    "finish" the condition wizard

    Save the form without the condition (the important part that I missed earlier)

    Checked the form and all else was operating as expected

    Return to "conditions"

    create a new condition from scratch to replace the deleted one.

    Tested and working

  • Profile Image
    Ben
    Answered on December 03, 2014 at 04:01 PM

    Hi Samantha,

    Thank you for the update.

    I was just about to reply to you when you have posted the solution that worked for you :)

    I will still raise this to our developers so that they can inspect what was wrong in the first place - just letting you know so that you are not surprised once the thread is updated by them.

    Do let us know however if you experience any further issues with conditions and we would be happy to help.

    Best Regards,
    Ben