IE issue

  • Profile Image
    bghoro
    Asked on September 28, 2011 at 09:14 AM

    Hi guys,

    I need your help. Your product is more than fantastic but I have a problem with the Cyrilic languge. In Mozilla everything is fine but once a user submits the form through IE it sends only question marks instead of symbols. I am using the Arial font as being most simple.

     

    Please advise if I can do anything to fix it.

     

    Best regards,

    George

  • Profile Image
    paoloumali
    Answered on September 28, 2011 at 03:23 PM

    Hi bhoro,

    I'm thinking that something in IE is causing this so I googled and found a user having the same problem although not necessarily with JotForm.

    http://support.microsoft.com/kb/934362

    Like you mentioned, your page looks ok with Chrome and Firefox.

    Support might be able to check if there's something special or particular with IE that could be done in the server's end.

    For a second opinion, maybe Microsoft can give some advice if there's something that needs to be configured with the PC.

  • Profile Image
    bghoro
    Answered on September 29, 2011 at 04:04 PM

    I've tested it on Opera also and it again was ok. The only problematic browser is Internet Explorer. There is no way I can make users use a browser different from IE. I've changed the encoding with all cyrilic encoders available but it didn't work.  We've tested it on explorer using Unicode(UTF-8). This code is being used by Mozilla too. We had no luck again.

  • Profile Image
    mliz
    Answered on October 01, 2011 at 01:51 AM

    Hi,

    I cloned the form and using the direct url I tested it using IE, the email notification displayed the cyrillic characters fine. Can you try filling out the form using the direct url:
    http://www.jotform.com/form/12241039000

    If it works fine then please use the iframe code on your website:

    To get the iFrame code please do the following:
    1. Open "Setup & Embed" tab on toolbar,
    2. Click on "Share Form"
    3. Click on "iFrame Code". 

    Let us know if this works for you.

  • Profile Image
    bghoro
    Answered on October 04, 2011 at 03:02 PM

    It works!!! I used the iframe and changed only the width otherwise it is huge but it works. I used the source the first time and not the iframe. Well... the festival is over and the form will be used again next year but at least it will be workng with every browser. Thank you very mich for your support and for your time.