What is JotForm?
JotForm is a free online form builder which helps you create online forms without writing a single line of code. No sign-up required.

At JotForm, we want to make sure that you’re getting the online form builder help that you need. Our friendly customer support team is available 24/7.

We believe that if one user has a question, there could be more users who may have the same question. This is why many of our support forum threads are public and available to be searched and viewed. If you’d like help immediately, feel free to search for a similar question, or submit your question or concern.


  • Profile Image

    Issues with Solve 360 CRM Integration

    Asked by fundcapital on December 11, 2014 at 02:41 PM

    Hello,

    I created a new form yesterday and we have embedded it in our website.  I connected the form to Solve and did a test yesterday and the information went into our Solve CRM database.  However, I did a few more tests but the information is not going into Solve anymore.

    The form is called 'Contact Form' and we would like it to work exactly like 'Online Plaintiff Cash Advance Request Form'

    Please advise.

    crm solve contact form
  • Profile Image
    JotForm Support Manager

    Answered by Jeanette on December 11, 2014 at 04:33 PM

    Can you please try to rebuild the integration? We had a temporary glitch with our email service, integrations might have been affected. Otherwise, do get back to us so we can further assist you.

  • Profile Image

    Answered by fundcapital on December 11, 2014 at 05:12 PM

    Hi Jeanette,

     

    I just tried using both forms and again, information submitted through the 'Contact Form' did not go through Solve.  The one from 'Online Plaintiff Cash Advance Request Form (Client)' went through just fine.

  • Profile Image

    Answered by Ben on December 11, 2014 at 06:27 PM

    Hi,

    It is possible that you have had an issue with your cache.

    I have just cleared it for you, but would recommend next steps:

    1. remove the integration on the one jotform that is not working
    2. clear your jotform cache
    3. re-integrate to Solve CRM.

    We did have several cases where the issue was caused by the browsers cache, causing bad response to be returned back to the jotform, so it might be good to try clearing it as well before you try the steps above.

    Do let us know how it goes for you.

    Best Regards,
    Ben

  • Profile Image

    Answered by fundcapital on December 11, 2014 at 06:46 PM

    Hello,

    I did all the steps but to no avail.

  • Profile Image

    Answered by Ben on December 11, 2014 at 07:10 PM

    Hi,

    I am sorry to hear that. Now can you please tell me if the fields match the ones in the Solve list?

    For example, if you have a name field in Solve CRM, it would be best to map it to the Full Name tool that we have under the Quick Tools. The same goes for email.

    I mention this since I saw that you are using plain text box on your Contact form, while these fields/tools will send the data in the right format to each of the integrations that we have - the text box will send it as a plain text instead. I understand that you have already managed to map the same type of fields on your other jotform, but for stability and compatibility it is always best to use matching fields.

    I would also like to ask you if you can try mapping only few fields instead of all and see if that helps you to connect and submit data - I ask this since I am a bit of suspicious about the apostrophe in the label "Law Firm's Name".

    Best Regards,
    Ben

  • Profile Image

    Answered by fundcapital on December 11, 2014 at 07:32 PM

    It's true that I use plain text instead of the ones under Quick Tools.  If I use the fields in Quick Tools, I will not be able to map it because they don't show up during the integration.

  • Profile Image
    JotForm Support

    Answered by ashwin_d on December 11, 2014 at 11:59 PM

    Hello fundcapital,

    I am not sure why the fields under quick tools does not appear in mapping. I did test the Solve360 integration with one of my own form and I am unable to replicate the issue. Please check the screenshot below:

     

    Can you please confirm if you have customized the form fields of Solve360 contact? 

    We will wait for your response.

    Thank you!

  • Profile Image

    Answered by fundcapital on December 12, 2014 at 11:40 AM

    Yes we have lots of customized form fields in Solve360.

    However, the issue of the form not sending the information to Solve is still there regardless if I use plain text field or the ones in quick tools.

  • Profile Image
    JotForm Support

    Answered by david on December 12, 2014 at 01:12 PM

    Hi,

    I also tested the Solve360 integration and the form fields I added went through without issue:

    It may be that your API key is either different than it was originally or is not allowing things to go through.  I would try removing your current key, issuing a new one, then trying the integration once again. 

    http://www.formdesk.com/manual/Webhook_Solve360_2

    As far as I can tell from my testing though, the integration is functioning as expected.

  • Profile Image

    Answered by fundcapital on December 12, 2014 at 03:33 PM

    Hello,

    I appreciate all your help.  Here's the current situation:

    Oinline Plaintiff Cash Advance Request Form (Client) --- Our original form and still working

    Oinline Plaintiff Cash Advance Request Form (Attorney) --- Cloned from the above form, integrated Solve and mapped all fields but information doesn't go to Solve.

    Contact Form --- created from scratch, integrated Solve and mapped some fields and also, information doesn't go to Solve.

     

    Your last suggestion is to:

    1. Remove existing API key from ALL 3 forms

    2. Regenerate a new API key

    3. Re-connect Solve to JotForm with the new key

     

    Is that right? If so, please tell me you have a back-up of these form so that in case it messes it up further, we can go back to the previous state.

  • Profile Image

    Answered by Ben on December 12, 2014 at 04:54 PM

    Hi,

    We do have a backup of all jotforms and their changes - which is used by our revisions tool, but the tool would restore the jotforms to their old API keys, so new keys would need to be added - reintegration would need to be made.

    If you are not sure if you want to do that, I suggest checking with Solve 360 support for possible limits with your API keys. If no limits or an issue is found on their side, I would strongly suggest following the steps as indicated by my colleague above.

    Just to confirm, have you tried this with another browser - consider trying to create the integration with both FireFox and Chrome browsers.

    Best Regards,
    Ben

  • Profile Image

    Answered by fundcapital on December 12, 2014 at 10:42 PM

    Okay,

    - I removed the Solve integration on all 3 forms.

    - Regenerated a new API key

    - Re-integrated Solve to our forms, of course, redo the mapping

    - Did some tests and guess what...

     

    ALL THREE OF THEM DID NOT TRANSFER THE INFORMATION TO SOLVE! SO I HAD TO REVERT THE WORKING FORM BACK.

    THIS KIND OF SUPPORT ISN'T GONNA WORK AND WE ARE STARTING TO THINK TO MIGRATE TO WUFOO INSTEAD!

     

  • Profile Image
    JotForm Support

    Answered by BDAVID on December 13, 2014 at 07:37 PM

    I think even if you use the Revision Tool to revert to a previous version, you still need to reintegrate with the new key.  

    It is quite odd is not working on your end, I did my test with the Solve360 integration, and it worked fine:

    I even cloned one of your form: http://www.jotform.us/form/31965579239167, then I removed some of the fields (Phone and Address field) and replaced with the ones from Quick Tools tab:

    I proceed integrating with Solve360, I mapped some field, and it went through just fine:

    Could you let us know in which browser have you proceed with the steps you have been given? Maybe you could try with another browser (Chrome and FireFox recommended). If you like, you might:

    1) Remove integrations

    2) Clear forms cache

    3) Get a new Key and integrating again with that new key

    4) Make sure you are using the field from Quick Tools tab.

  • Profile Image

    Answered by fundcapital on December 15, 2014 at 01:59 PM

    Everything's sorted out now.

  • Profile Image
    JotForm Support

    Answered by david on December 15, 2014 at 03:03 PM

    Hi,

    Glad to hear it!  If you don't mind sharing what the end problem was that would be very helpful when trying to resolve this issue for future users.  Thank you in advance.