What is JotForm?
JotForm is a free online form builder which helps you create online forms without writing a single line of code. No sign-up required.

At JotForm, we want to make sure that you’re getting the online form builder help that you need. Our friendly customer support team is available 24/7.

We believe that if one user has a question, there could be more users who may have the same question. This is why many of our support forum threads are public and available to be searched and viewed. If you’d like help immediately, feel free to search for a similar question, or submit your question or concern.


  • Profile Image

    Clients using Mozilla/IE are unable to move forward to the next page on form ("Next" button not working)

    Asked by cutandpastephotobooth on January 09, 2015 at 09:48 AM
    Page URL:
    www.cutandpastephotobooth.com/rent-a-booth

    next move button not working
  • Profile Image
    JotForm Support

    Answered by Charlie on January 09, 2015 at 11:35 AM

    Hi,

    Upon checking your account and form, I see that the standalone link (http://www.jotform.us/form/41263797742160) of your form works correctly in both Chrome, Firefox and IE, all with latest version.

    The next thing that I checked is your website link where the JotForm is embedded, I was unable to see the Form Tabs widget in IE.

    1. Here you will see that the widget "Form Tabs" is not displaying, this is the reason why you can't continue using the "Next" button.

    2. But a couple of refresh fixes the problem and the Form Tabs are now showing. 

     

    I see that you are using Squarespace in building your website? May I know how you embedded your JotForm? I would suggest that you re-embed your form's code using this guide that we have: Adding Form To Squarespace. The guide shows that you will use an iFrame, the iframe code makes a good choice because if closes your form from other script codes that may conflict your widgets or your form's function.

    Or you can also remove the "Form Tabs" widget if it is not that essential in your workflow process. But, please do try re-embedding first and see if that fixes that problem.

    Thank you.