Problem using the Designer & Preview doesn't match Form

  • Profile Image
    MissMarudek
    Asked on January 15, 2015 at 09:33 AM

    Hello,

    I've been trying to create a form and I'm currently having two problems.

    1. I've used the Designer to customise the width of the Matrix Table column text boxes and in the Designer Preview it seems that I have successfully managed to do so. However, when I return to the form builder those changes are not reflected and the matrix columns are as tiny as ever.

    2. When I preview the form from the Form Builder Preview Button, the matrix table is as I want it (i.e. it reflects the changes I've made using the designer) but my other labels are all messed up, in that labels that I have shrunk for them to fit in the same row are now sitting one below the other occupying different lines.

     

    Can you please help me? Please keep in mind that I am not at all familiar with HTML and CSS.

    Thank you very much in advance.

    K.

  • Profile Image
    Welvin
    Answered on January 15, 2015 at 11:39 AM

    Hi K,

    But the way you want it to look like, is correct in the form view, right? The important thing is it's working in the form view.  I think that happened because you're only targetting the input boxes, not the overall matrix such as the columns and rows.

    Your second problem related to the field alignments has been moved to a new thread, kindly check it here: http://www.jotform.com/answers/496787.

    Thanks

  • Profile Image
    Katerina
    Answered on January 22, 2015 at 05:50 AM

    Hi Welvin,

    Thanks for your answer.  Do I understand you correctly that what matters is how a form looks when one uses the form preview and that however a form looks then, this is how it's going to look when uploaded to a website?

    thanks again.

    K.

  • Profile Image
    Welvin
    Answered on January 22, 2015 at 07:48 AM

    Hi Katerina,

    Yes, that is correct. Preview and when you embed it should looks exactly the same.

    Thanks