What is JotForm?
JotForm is a free online form builder which helps you create online forms without writing a single line of code. No sign-up required.

At JotForm, we want to make sure that you’re getting the online form builder help that you need. Our friendly customer support team is available 24/7.

We believe that if one user has a question, there could be more users who may have the same question. This is why many of our support forum threads are public and available to be searched and viewed. If you’d like help immediately, feel free to search for a similar question, or submit your question or concern.


  • Profile Image

    Geolocate widget reports incorrect Street Address

    Asked by Aaardvaark on January 15, 2015 at 11:10 PM

    I don't know what has happened to my previous reporting of problems with geolocate, but it seems to have changed its behaviour.  It now reports street address.

     

    Now I just tested it.

     

    If you update the location by dragging, it works ok.

     

    But if you update location by double clicking, it reports the correct lat/long but the original, now incorrect, address.

    Page URL:
    http://canberrabirds.org.au/observing-birds/gang-gang-survey/gang-gang<br/>-muster-instructions/

    Reports reporting street address
  • Profile Image
    JotForm Support

    Answered by jonathan on January 15, 2015 at 11:51 PM

    Hi,

    You must be referring to the same bug on the widget you reported here http://www.jotform.com/answers/482651

    The ticket is still open and already on the hands of our dev team.

    We ask for your patience and understanding since it is taking more time than what you expected.

    I assure you though that it is not being neglected and will be attended to as soon as available.

    We will let you know for any update on the status as soon as we can.

     

    Thanks.

     

  • Profile Image

    Answered by Aaardvaark on January 17, 2015 at 05:27 AM

    Hi - I am patiently waiting to hear about my original bug, but this is not the same bug. My new bug it this - previously the widget did not report the street address, at least it didn't report streeet address to my form --  it only reported lat and long. Now it also reports nearest street address, though not always correct. 

    re my earlier bug reported here http://www.jotform.com/answers/482651, this seems to be fixed.  No-one has reported any change but the behaviour is different. Now (this is new behaviour) I am asked if I want to share location info, when I say yes, the correct map near my location appears immediately.

    To be clear:

    ORIGINAL ISSUE http://www.jotform.com/answers/482651,

    1---Originally (a year ago) - correct local map appeared in geolocate widget  more or less immediately with no prompt. (Not at my exact location but within 30km, on my desktop).

    2---About a month ago - map took a long time to appear and defaulted to NY.

    3---Now - browser requests permission to access location info and then map appears immediately, within 30km.

     

    NEW ISSUE http://www.jotform.com/answers/497295

    Originally - geolocation widget only returned two fields - lat and long.

    Now - geolocation widget returns several fields - lat, long, street address. I have not seen documentation of this change.  Street address is not correct if you double click map, it is correct if you drag marker.  From a user POV this has nothing to do with the map delay/ NY problem, though of course both issues might have started at the same time due to some un-announced changes.

  • Profile Image
    JotForm Support

    Answered by jonathan on January 17, 2015 at 09:13 AM

    Hi,

    Thank you for the clarification and providing more details.

    I can see the changes that you have mentioned and it is indeed incorrect.

    Actually even if you drag the marker it will still give a wrong address.

    I test submitted the form http://www.jotformpro.com/form/50148390451956 and the result 'Street Address' is way of.

     

     

    I have submitted this thread to our higher team support so that it can be checked.

    We will let you know once we have update on the status.

     

    Thanks.

     

     

     

     

  • Profile Image
    JotForm Support

    Answered by widgets on February 05, 2015 at 12:56 AM

    Hi, we're sorry about this glitch and for the late update. It has bow been fixed.

    Please make a test and let us know if the problem still persist.

    Regards,
    Widget Team

  • Profile Image

    Answered by Aaardvaark on February 05, 2015 at 05:21 AM

    Sorry, still doesn't work on my machine. (I've reloaded the form, etc).

     

    Re-explanation
    *************

    When the map opens, it shows the teardrop marker at the machine's best guess of your location.  On my desktop the location is only approximate because I don't have GPS (like most desktops and some tablets, and all tablets and phones with GPS turned off).

    In my case the initial teardrop marker location is always about 20km away from my actual location.

    So I need to move the marker from there to the correct address, to my actual location. There are two ways of doing this.

    1) zoom and drag the marker, drag the map, drag the marker some more, and finally leave it at the right spot.

    OR

    2) drag the map until your can see your correct location, and zoom in for accuracy.  At this time the marker is way outside the map, not visible any more.  So you double click on the map at the correct spot, and the marker appears at that spot.

    If you use method 1), the location is reported accurately by the widget at the place you left the marker.  But if you use method 2), the widget reports your location to be at the original marker position, not the place where you left the marker by double clicking.

     

    AN EXAMPLE: In my case the original address where the marker appears when the map opens is:

    13 Allport Street, Downer ACT 2602, Australia
    -35.24769, 149.14436
    I guess this is the location of a server or something.  It is always the same location.

    My actual address is about 20 km south, at:

    Address: 44 Jerrabomberra Avenue, Narrabundah ACT 2604, Australia
    Latitude: -35.33887
    Longitude: 149.15037

    Now, if I drag the MARKER from Allport St Downer to Jerrabomberra Av Narrabundah, then the address and coordinates are reported correctly in the form response, as 44 Jerrabomberra Av Narrabundah.

    But if I drag the MAP to show 44 Jerrabomberra Av,  then double click at the right spot, the marker appears at that location OK, but when I submit the form my address is reported to be

    13 Allport Street, Downer ACT 2602, Australia
    -35.24769, 149.14436

    This address is incorrect,  and means if my users double click instead of zoom/drag map/ drag marker, then their reported locations are completely wrong.

    I just submitted another test and the problem still remains on my machine.

  • Profile Image
    JotForm Support

    Answered by widgets on February 05, 2015 at 05:41 AM

    Hi, the double click for marker to get the location is working fine on our side. However, from your explanation we concluded that it might be your form and widget cache which was causing the error.

    We just cleaned it for you so please do some test again and report back if its still not going to work.

    We test it several times now to check if we can get the proper location on drag and on double click for the markers and they worked just fine on our end.

    We apologize for any inconvenience that this may have caused you. We will ensure that this widget will be running smoothly to your forms.

    Regards,
    Widget Tem

  • Profile Image

    Answered by Aaardvaark on February 05, 2015 at 06:24 AM

    Thanks!!! It seems to work fine now.

    How do I clear my form and widget cache please?

     

    Cheers

    Julian

  • Profile Image

    Answered by Sean on February 05, 2015 at 09:57 AM

    Hello Julian,

    I am glad that you got your issue resolved. Feel free to contact us if you ever need our support. We are always willing to help out.


    Cheers!
    Sean