What is JotForm?
JotForm is a free online form builder which helps you create online forms without writing a single line of code. No sign-up required.

At JotForm, we want to make sure that you’re getting the online form builder help that you need. Our friendly customer support team is available 24/7.

We believe that if one user has a question, there could be more users who may have the same question. This is why many of our support forum threads are public and available to be searched and viewed. If you’d like help immediately, feel free to search for a similar question, or submit your question or concern.


  • Profile Image

    Hidden fields showing on PDF

    Asked by Emily on January 27, 2015 at 09:24 AM

    Hello,

    On several of our forms, hidden fields are starting to show up in our PDF submissions. These fields should not and have not ever shown up before.

    In our form http://www.jotformpro.com/form/40635282858967, you can see that the PDF for submission with Unique Order ID 261 shows every preset field, even though no preset was selected, and none of these fields show when filling out the form.

    The same is true for Order ID 52 on form http://www.jotform.us/form/40517025500137.

    Please let me know as soon as this gets fixed, as it is really bogging down our order processing.

    Thank you!

    Emily

    Page URL:
    http://www.jotformpro.com/form/40635282858967

    submission pdf
  • Profile Image

    Answered by Carina on January 27, 2015 at 10:34 AM

    Hello Emily

    I inspected the forms and everything seems to be normal. As you have several conditions and several email notifications I will run further tests to try to determine the cause of this situation. Have you edited recently any email notification?

    Thank you 

    I will let you know more as soon as I have more details.

    Let us know if we can assist you further.  

  • Profile Image

    Answered by ebartosh on January 27, 2015 at 01:38 PM

    Hi Carina,

    I have not done any editing recently to the email notifications. The problem doesn't seem to be with the emails themselves, since all of the hidden fields are showing up in the PDF's.

    I just received another submission and it had the same problem.

    Thanks for your help in getting this fixed.

  • Profile Image
    JotForm Support

    Answered by Mike on January 27, 2015 at 03:59 PM

    For some reason, the submission #261 has filled conditional fields, so that is why they are being added to the PDF.

    I was not able to reproduce this issue on a cloned version of your form, and your other submissions seems to be fine. If you notice the issue once again, please let us know. Also, provide us with information about the version of the internet browser used to submit the entry if possible.

    Thank you.

  • Profile Image

    Answered by ebartosh on January 27, 2015 at 05:45 PM

    That is what appears to be happening, but as you can see, none of the conditions that trigger the pre-filled fields to show have been met.

    I will let you know if the issue persists. We are using Internet Explorer 11.

    Thank you!

  • Profile Image
    JotForm Support

    Answered by Mike on January 27, 2015 at 06:34 PM

    In case the form is embedded on some web page, you might try to use an iFrame form code. The iFrame can help in avoiding possible script conflicts between form and other scripts on the page.

  • Profile Image

    Answered by ebartosh on January 28, 2015 at 09:41 AM

    Hello,

    The form is not embedded on a web page.

    This is continuing to be a problem on almost all of our forms.

    As an example, please see our form http://www.jotformpro.com/form/33635518898975 Unique ID 332, and http://www.jotform.us/form/40076333720143, Unique ID 228.

    This is really starting to be a big issue for us and a huge inconvenience - can you please look into this and see why all of these pre-filled, conditional text fields are showing up on our PDF's, even though the conditions for showing them have NOT been met?

    This is urgent, thank you for your prompt attention!

     

     

  • Profile Image

    Answered by ebartosh on January 28, 2015 at 10:24 AM

    Hello,

    I noticed that you sent through a test, which probably did not replicate the problem.

    To replicate the problem, you will need to select a preset customer on the first page, click "yes" on the last questions on the first page, and complete the next two pages and then submit.

  • Profile Image

    Answered by Carina on January 28, 2015 at 10:33 AM

    Thank you for providing adittional information.

    I made test submissions with IExplorer 11 and the PDFs only displayed selected fields:

    I will make further tests to try to determine the cause, but as I'm not able to replicate the problem it might be difficult.

    Let us know if we can assist you further.  

  • Profile Image

    Answered by ebartosh on January 28, 2015 at 10:35 AM

    Hi Carina,

    Please see my last submission here. The reason you're not able to replicate the problem is because you did not select a preset customer on the first page of the form. The problem is only happening when a preset customer is selected.

    Thank you!

  • Profile Image

    Answered by Carina on January 28, 2015 at 10:42 AM

    Sorry I made several submissions and end up posting the screenshot of a previous one. I also tested with preset customer and the PDF only showed selected fields:

    I will continue further tests.

    If you need further assistance please let us know as we're here to help.

  • Profile Image

    Answered by ebartosh on January 28, 2015 at 10:47 AM

    Ahh, okay! Thanks for clarifying, Carina.

    My last suggestion for a test would be uploading files on that third page, right before you submit (following the same procedure of selecting a preset customer, then "yes", etc.).

  • Profile Image

    Answered by Carina on January 28, 2015 at 11:28 AM

    Thank you, that suggestion is very valuable. I will take that in consideration on my tests.

    If you need further assistance please let us know.

  • Profile Image

    Answered by ebartosh on January 29, 2015 at 10:50 AM

    Good morning,

    As this problem still was not fixed this morning, I decided to revert our forms to a version prior to 01/23. We were able to determine that this problem started over the weekend, which is evidence that it is not an issue due to a change we made.

    However, when I went to revert our form http://www.jotform.us/form/40405807726151 to a previous version, I was surprised to discover that there was no revision history, except for 475 updates that took place yesterday (see image below), where every single field and condition was "added" to the form. Do you have any idea what happened here? I have no previous version to revert back to, and thus we have no way to keep these hidden fields from showing up on our PDF's.

    I appreciate your help, but this is incredibly frustrating.

  • Profile Image

    Answered by Carina on January 29, 2015 at 12:39 PM

    I'm very for all this situation but I still cannot replicate this situation. I believe this might be some kind of bug with the conditions, but as I cannot replicate it it is not possible for me to determine the cause.

    Do you know if the browser used was always IExplorer 11? Also do you know which OS was used on the problematic submissions?

    I moved the other revision history situation to a new thread as it might be another situation.

    Thank you for helping us understanding better this situation.

    Let us know if we can assist you further.   

  • Profile Image

    Answered by ebartosh on January 29, 2015 at 01:00 PM

    Hi Carina,

    I do appreciate you continuing to look into this.

    On that last test that was sent through, I believe you clicked "Next" instead of submitting on the 4th page. I'm sorry, I know that our forms are quite complicated and I should have mentioned this earlier, but the issue will only happen on submissions that get submitted on the earlier screen.

    How our process goes is that if a job needs to be quoted, it is submitted on the Install Quote page. Our installation manager then receives the submission, goes back in to the form, fills in his quoted numbers, then submits back to our salesperson for their approval. The salesperson then goes back into the form and completes it the entire way through.

    If it would be helpful to talk this out on the phone, I would be happy to do so, as again I know it may be difficult to understand how our form flows.

    Thank you!

  • Profile Image

    Answered by Carina on January 29, 2015 at 02:25 PM

    I made another test submission but still could not replicate the problem. Until I can replicate the problem it is very hard to determine the cause, because I cannot confirm that the action I did had any results.

    When the problem is not immediately visible, we try to determine the causes/solutions by performing action and test, action and test, action and test, and so on until we find the root of the problem. But by not being able to reproduce it it is very hard to determine the cause of this situation. Are you able to reproduce it? 

    Also it is happening very sporadically: 

    3/12/2014
    28/1/2015
    26/1/2015

    I will try to find a common ground that might be triggering this situation. If you have additional information that is always helpful.

    Thank you

     

     

  • Profile Image

    Answered by Carina on January 29, 2015 at 10:15 PM

    Hello Emily

    I tried to gather additional information in order to escalate this situation to 2nd level. I believe until now we have 4 submissions, one of them still in December:

    33635518898975 - ID 332 - 12/03/2014

    40635282858967 - ID 261 - 01/26/2015

    40517025500137 - ID 52 - 01/26/2015

    40076333720143 - ID 228 - 01/28/2015

    Is this correct?
    Our developers will look into it and contact you via this thread once they have an update on this.

    Let us know if we can assist you further.   

  • Profile Image

    Answered by ebartosh on January 30, 2015 at 09:22 AM

    Hi Carina,

    On that form, I believe that is correct.

    Please note that it is happening on ALL of our forms now that have a name (e.g. "Jeff Sacco," "Shannon Prince," "Anna Anderson," "Kathy Nichol," etc.).

  • Profile Image

    Answered by Carina on January 30, 2015 at 12:09 PM

    Thank you for the update.

    I checked and there were more 2 forms:

    33515001001127 - Christy Egart  - ID 234

    40405807726151 - Shannon Prince 

    I will inform our developer. The ticket was considered urgent and is already assigned to a developer.

    Let us know if we can assist you further.   

  • Profile Image
    JotForm Support

    Answered by alp_deniz on February 04, 2015 at 07:37 AM

    Hello Emily,

    Thank for sharing your needs.

    I have looked into the issues and, unfortunately, couldn't make a final decision yet whether to hide or show hidden -but filled- fields in PDF exports since PDF export should include all of the information in the form. So it is a special case where you don't want to have hidden field information in your export.

    Fortunately, we are on the verge of announcing a PDF designer so that you can choose exactly which fields to include/show.

    I will include your request to our PDF designer feature and let you know when it is released.

    Thank you very much

    Kind regards

     

  • Profile Image

    Answered by ebartosh on February 04, 2015 at 09:26 AM

    Hello,

    I'm afraid I'm skeptical that this is the problem, as it only started happening the 24th of January.

    If you look at the submission history on any of our forms, you will see that the conditionally hidden fields did not EVER show up on our PDF's prior to this. On any of our submissions where the "Installation Quote" page is skipped/not needed, the pre-filled fields show and hide on the PDF's as they should.

    Again, if it would be helpful to set up a phone call to discuss this (I know our forms are large and complicated, and can be confusing if you don't understand how we use them), I would be more than happy to talk some of this out, as this is continuing to cause problems for our entire company.

    Thank you!

  • Profile Image

    Answered by Carina on February 04, 2015 at 10:45 AM

    Hello Emily

    I'm very sorry that this situation is still happening, but as I mentioned before, as it is an intermittent situation it does not help to determine the cause.

    Maybe you could try to clone one of the trouble forms, like Jeff Sacco, and try to see if this situation is still happening on the new cloned form.

    Thank you for your availability in providing additional information via phone, but unfortunately we don't have phone support.

    I will update the ticket with this additional information.

    Let us know if we can assist you further.   

  • Profile Image

    Answered by Emily on February 18, 2015 at 05:07 PM

    Hello,

    I've been doing a lot of troubleshooting on this issue, as it is still happening with all of our "named" forms (e.g. "Shannon," "Jeff," etc.), and have a few updates that might be helpful for you.

    First of all, I have discovered that this now happens every time the form is accessed a second time, i.e. edited from the "Edit Submission" link in the email confirmation, and resubmitted. The issue also happens on the cloned forms (I cloned "Jeff Sacco" for testing).

    I'm hoping that this gets us closer to a breakthrough - thank you all for continuing to look into this!

    Emily

  • Profile Image
    JotForm Support

    Answered by Mike on February 18, 2015 at 06:40 PM

    Thank you for your update, it really helps.

    I was able to reproduce the issue on a test form. There is some bug related to submission edits. All the conditionally hidden fields are being included into submission data upon the edit.

    We will get back to you as soon as it is fixed.

  • Profile Image
    JotForm Support

    Answered by alp_deniz on February 18, 2015 at 07:05 PM

    Great help!! Thank you very much for figuring it out so quickly, as it will be fixed as soon as possible.

    I will update here when it is completely cleared.

    Kind regards,

    Alp

  • Profile Image

    Answered by ebartosh on February 24, 2015 at 05:09 PM

    Hello!

    I was wondering if you have an update on this issue?

    Thanks so much!

    Emily

  • Profile Image

    Answered by ebartosh on March 25, 2015 at 02:19 PM

    This issue is still affecting all of our forms, and we are having to print many pages of irrelevant information for each submission.
    Please provide an update, thank you.

    Emily

  • Profile Image
    JotForm Support

    Answered by Mike on March 25, 2015 at 03:39 PM

    The ticket is still open and marked as very important. We do not have any other updates as of this time, but we will let you know when we have any news on this.

    We are sorry for the delay.

  • Profile Image

    Answered by coigis on May 28, 2015 at 07:05 PM

    I wonder what's the status on this issue because all my hidden fields also show up in the pdf.

  • Profile Image

    Answered by raul on May 28, 2015 at 08:11 PM

    @coigis

    Unfortunately, there are no updates regarding this ticket yet.
    The assigned developer is working on it.

    But, since you have posted on this thread. You'll be also notified as soon as we have any news on this matter.

  • Profile Image
    JotForm Support

    Answered by alp_deniz on September 27, 2015 at 05:07 PM

    Hello,

    Please accept my apologies for this delayed reply.

    I have conducted extensive tests and I am now able to confirm that everything works as expected. However, it will be good to emphasize two points:

    - To hide hidden fields in PDF's it is necessary to disable them in the submissions page's settings (gear icon)

    - PDF layout is now editable via "submissions page -> click Get PDF -> Customize PDF". With the submission PDF editor, you may now design the layout, show/hide fields or change the look and feel of the PDF output for downloads and integrations.

    Thank you very much for your patience.

    Kind regards

  • Profile Image

    Answered by r83rob on November 10, 2016 at 12:59 PM

    My hidden fields all show up. There is no option to hide them in the submission editor PDF section as you describe only to delete them. At which point my form does not have the field that is Not hidden when filled out in it. I have it set up so only one version of a field is shown and the rest hidden. It used to work on the PDF off of the submissions but now either they all show up or only the ones I have not deleted in the PDF editor part of the submission as you describe. Help please!

    https://form.jotform.com/60687321020143