I was told I must upgrade because of SSL submissions. It was a mistake!