What is JotForm?
JotForm is a free online form builder which helps you create online forms without writing a single line of code. No sign-up required.

At JotForm, we want to make sure that you’re getting the online form builder help that you need. Our friendly customer support team is available 24/7.

We believe that if one user has a question, there could be more users who may have the same question. This is why many of our support forum threads are public and available to be searched and viewed. If you’d like help immediately, feel free to search for a similar question, or submit your question or concern.


  • Profile Image

    Two Conditions Aren't Working Right - Please Help

    Asked by s.couch360 on January 29, 2015 at 10:40 AM

    My form: Platinum Sponsor Response Form has many conditions. Almost all of them work perfectly.

    http://form.jotform.us/form/50256482832153

     

    The last two conditions are not working right.

    Under the Section towards the bottom of the form: Invite Friends and Family

     

    The Question" Choose your Friends and Family Ticket Choice' has 3 choices

         1. I don't plan to purchase any Friends & Family tickets (condition to hide questions below work fine)

          2.  I would like to purchase TWO additional tickets

          3.  I would like to purchase ONE additional ticket

     

    When someone chooses "I would like to purchase TWO additional tickets'

        It should HIDE the question below: "Please chose your ONE additional ticket   - But it shows it

     

    When someone chooses "I would like to purchase ONE additional ticket'

         It should HIDE the question below  'Please chose your TWO additional tickets' - BuT it shows it

     

    Can someone check my conditions and let me know what I'm doing wrong? I tried reversing the order of the two conditions to see if it was a Priority issues, but get the same results.  I've tried deleting the conditions and recreating them... I've checked question properties -- I'm stumped.

    Thank you very much!!!

    response form purchase check choices
  • Profile Image
    JotForm Support

    Answered by EltonCris on January 29, 2015 at 01:51 PM

    Hi,

    It's a conflict with conditions from your first condition and the last ones you've added. That's the main reason why it's not working properly.

    I've managed to find a way on a cloned version of your form by grouping the fields using form collapse and then use it on your first condition so the last condition would work as expected.

    Here's a working version of the form: http://form.jotformpro.com/form/50285797604969?

    You may clone this form back if you want to, guide: http://www.jotform.com/help/28-Cloning-a-Form-from-a-Web-Page

    Thank you!

  • Profile Image

    Answered by s.couch360 on January 29, 2015 at 02:13 PM

    Your clone of the form works perfectly! The solution to over 20 personal hours of ineffective effort.

     

    HOWEVER, while I feel very clear on how to clone your working version back to my Forms, it doesn't appear to be working...   Will it 'overwrite' my current form or appear as a 'clone'?


    I've followed the procedures (sound simple) but no clones show up, and the conditions in my current form don't appear changed...  I tested my current form again with same previous wrong results.

     You are so kind to help... can you help me through this final phase of getting your cloned form to be my new Platinum Sponsor Response Form?

    Grateful,

    !!!!!

  • Profile Image

    Answered by s.couch360 on January 29, 2015 at 02:25 PM

    OKAY!  Mr EltonCris, I figured it out.  I needed to change my account to allow forms to be cloned.  Now I have your new, perfectly functioning form.  I can't thank you enough.

     

    I'm really under the gun to get my forms out - and you saved my behind!!!

     

    JotForm and its members are the greatest.

     

    My very sincere thanks!

  • Profile Image
    JotForm Support

    Answered by EltonCris on January 29, 2015 at 02:33 PM

    I was about to respond you but I see you have figured it out. Glad to be of help.

    Feel free to contact us again should you need anything else. We'd be more than happy to help.

    Cheers! :)

  • Profile Image

    Answered by s.couch360 on January 29, 2015 at 03:22 PM

    OH DEAR, I may have blown it.  

    Somehow I've ended up with three forms... none of them working like your clone.

    And none of them are your clone.... http://form.jotformpro.com/form/50285797604969?

    I have (Plat forms) with end IDs 155, 153, and 158 - they are old conditions.

    I have tried to clone your form 969 but it doesn't appear in my FORMs....I have enabled cloning in my account... dang.  I hope I didn't screw anything up.

    I hope that you didn't do all of this work to help me only to have me blow it away..... I'm so very sorry.  

    Are you willing to re-visit?  Help me understand where I blew  it if I did....

    Thanks in advance.  PS, I notice 'pro' in your URL.  Is it because I am not a PRO subscriber???

  • Profile Image

    Answered by s.couch360 on January 29, 2015 at 04:04 PM

    Having the SAME problem with my GOLD Sponsor form... Same questions/same desired 'hide' questions....two zones on the form...

    http://form.jotform.us/form/50285993251157

     

    I thank you again for your help....

     

  • Profile Image
    JotForm Support Manager

    Answered by Jeanette on January 29, 2015 at 06:05 PM

    @ s.couch360  

    If the form is exactly the same, an easier way to solve this is to clone the working form, here is how:

    http://www.jotform.com/help/42-How-to-Clone-an-Existing-Form-from-a-URL

    You must paste this link on the URL field: (this is Elton's working form)

    http://form.jotformpro.com/form/50285797604969

    Then you can rename the form title accordingly.

     

     

  • Profile Image

    Answered by s.couch360 on January 29, 2015 at 06:28 PM

    Thank you Jeanette, I have tried using the method you suggest--several times. It seems quite simple. I made sure that my 'settings' allowed form cloning. I don't receive an error message... but the clone doesn't download to My Forms.

     

    I cannot clone the working form (Elton's '969').  It will not generate a clone in My Forms.

     

    I am wondering if the problem has anything to do with the fact that Elton's form is a "JotformPRO' form, and I am not a Jotform PRO subscriber. That's the only possible issue I can think of. If anyone has any suggestions, please share them.... I will be greatly appreciative.

     

    Kindly,

    s.couch360

  • Profile Image
    JotForm Support

    Answered by EltonCris on January 29, 2015 at 09:26 PM

    @s.couch360

    My apologies for the delayed response.

    You should be able to clone forms from any domains. Anyway, I have imported my demo form to your account for your convenience. I have name the form "Imported by Elton: CAMP Rehoboth Women's FEST Platinum Sponsor Form" so you can easily find it. It should be on your my forms page now. Kindly check.

    Feel free to contact us again if you have more questions. Thank you!

  • Profile Image

    Answered by s.couch360 on January 29, 2015 at 09:57 PM

    Thank you Elton, no need for an apology, you are fantastic!.  I 'cloned' your imported form so that I could examine how you cleverly used form collapse and the conditions fields, and I think that I can now structure another 'problem' form properly. I'll let you know if I need assistance, but just having an opportunity to see how you handled the Platinum form helps me tremendously.

     

    Thank you and have a great evening!

     

    s.couch360

  • Profile Image
    JotForm Support

    Answered by EltonCris on January 29, 2015 at 10:02 PM

    Great! Thanks :)

    I have also imported the second form, it's named

    This time without using form collapse. I have only removed the following fields on the conditions where it us used.

    "Please select your two..."

    Please select your one.."

    Then I did the following conditions:

    They are pretty similar, you just have to create a new rule for "is filled", then select "if all" and use show instead of hide.

    Hope this helps. Thank you!

  • Profile Image
    JotForm Support

    Answered by EltonCris on January 29, 2015 at 10:11 PM

    @ s.couch360

    By the way, with regards to cloning form problem, would you mind creating a separate thread about it in detailed? I think I was able to reproduce the problem but I would like to confirm it from you so I can forward it to our developers for a resolution. You can create a ticket here https://www.jotform.com/answers/answer.php?. Let us know what happens when you press the continue button.

    Thank you!