I agree to Terms and Conditions - html keeps disappearing

  • Profile Image
    Asked on October 13, 2011 at 07:51 PM

    Hi there

    On my form http://www.jotform.com/?formID=12752959117 / http://www.jotform.com/Bruum/MHASubscribe I have an "I have read and agree to the terms and conditions" and the TandC links off to our website.

    I followed the instructions here http://www.jotform.com/help/76-How-to-add-agreement-check-box-to-a-form but noticed when testing the form yesterday the link had disappeared.

    I have put the code back in again today:

    I have read and agree to the <a target="_blank" href="http://www.mhacloudcomputing.co.nz/top-navigation/subscriber-giveaway.aspx" >Terms and Conditions</a>

    It worked at first, then disappeared again, so have re-entered and seems to be sticking for now.

    Is there something I am doing wrong here?  We are sending links out to this form in the next day or two, and don't want the link to disappear again.

     

  • Profile Image
    fxr
    Answered on October 13, 2011 at 08:30 PM

    I dont see anything wrong with your set up. Its looks perfect.

    One suggestion I have is:

    Before the form goes live, exit any edit pane for that form that you have open.

    Inspect the live form, however & wherever you have it embedded.

    Then if its good, as much as is possible, try not edit the form once it goes live.

    With HTML like the link to your T&Cs here; There is a slightly greater potential for a form creator to inadvertently click something, delete a character or add an extra carriage return which could have a major impact on the code.

    I have tried to recreate the problem with no luck. Everything is fine, but if it does happen to you  again, let us know, include browser info & whether or not you had been editting the form before you noticed it had dissappeared.

  • Profile Image
    Bruum
    Answered on October 13, 2011 at 08:35 PM

    Thanks for the advice.  Will keep an eye on it and let you know if it happens again.