What is JotForm?
JotForm is a free online form builder which helps you create online forms without writing a single line of code. No sign-up required.

At JotForm, we want to make sure that you’re getting the online form builder help that you need. Our friendly customer support team is available 24/7.

We believe that if one user has a question, there could be more users who may have the same question. This is why many of our support forum threads are public and available to be searched and viewed. If you’d like help immediately, feel free to search for a similar question, or submit your question or concern.


  • Profile Image

    Conditions sporadically not activating on embed

    Asked by twrarepairexchange on January 31, 2015 at 08:53 PM

    Hi hi,

    I have a form set up (Round Three Submissions) for my users to submit their work for the challenge through. Since there are multiple types of work that could be submitted which require different information and some types have more than one submission channel (eg video can be uploaded to us or linked to on youtube) the form's set up to show relevant parts as the user selects answers and functions like a flowchart to guide them through the process.

    It works fine in the preview and it usually loads fine on the embedded page (ie the form briefly shows for a second until the conditions kick in and hide the other fields) however sometimes it loads but the conditions don't initiate, so the whole form remains visible even after the form is fully loaded (only the 'is this your main gift or a bonus gift' question should be visible):

    Is there a way to fix this? Or at least have a message visible asking users to refresh the page when it happens? I'm not sure if my conditions need optimising or if breaking the form into pages would help? Or if it would be better just to have separate forms for each submission type.

    embedded link: http://twrarepairexchange.tumblr.com/submission

    Thanks in advance. :)

     

  • Profile Image

    Answered by raul on January 31, 2015 at 09:51 PM

    This may be caused by a Javascript conflict, could you please try to use the iframe embed method instead? You would need to use the following code:

    <iframe id="JotFormIFrame" onload="window.parent.scrollTo(0,0)" allowtransparency="true" src="//form.jotform.co/form/42834110540847" frameborder="0" style="width:100%; height:4206px; border:none;" scrolling="no"></iframe>

    Here you can find how to embed iframes in Tumblr posts.

    Let know if this helps.
    Thank you.

  • Profile Image

    Answered by twrarepairexchange on January 31, 2015 at 11:24 PM

    Thank you! That worked great. :)

  • Profile Image

    Answered by Sean on February 01, 2015 at 09:39 AM

    On behalf of my colleague, you are more than welcome. Feel free to contact us if additional assistance is needed.


    Cheers!
    Sean