What is JotForm?
JotForm is a free online form builder which helps you create online forms without writing a single line of code. No sign-up required.

At JotForm, we want to make sure that you’re getting the online form builder help that you need. Our friendly customer support team is available 24/7.

We believe that if one user has a question, there could be more users who may have the same question. This is why many of our support forum threads are public and available to be searched and viewed. If you’d like help immediately, feel free to search for a similar question, or submit your question or concern.


  • Profile Image

    Continuing Salesforce Issue: For some reason, the JotForm event application (on our Wix website) is not sending info into Salesforce (see below)...

    Asked by thechevra on February 05, 2015 at 12:02 AM
    Hi -- below is the updated chain of correspondence thus far.  
    A few responses to Ashwin's questions:
    - We have the Enterprise edition for Salesforce
    - Yes, we have plenty of custom Salesforce fields -- but since they show up as mapping options, could that even be a possible source of the problem?
    - We have re-integrated the forms, but unfortunately, that doesn't seem to be helping (other than the fact that occasionally it does properly export to Salesforce following an re-integration, but usually not.  And unfortunately, it seems that every time we need to make even one field change, we then have to remap and reintegrate, which usually leads to a non-working integration)

    By the way, we have had our Salesforce Enterprise account customized with functionality that I believe is part of the Non-Profit Starters Pack (I'm mentioning this factor in case it might be contributing to the problem)

    2 questions (in addition my continuing question regarding how to resolve this issue):
    - Is there a way we can speak on the phone about this (and should I respond with my #, or would you like to perhaps provide yours)?
    - Is there a way I can respond directly to a thread (rather than re-posting everything anew each time)?
     
    Thanks so much!  Best, J
     
     
    ------------------------------------------------------------------
    Answered by ashwin_d

     

    Hello thechevra,

    I'm sorry for the trouble caused to you.

    I did check your account and found that there are several registration and contact forms. I did check few of your last edited forms and they seems to be integrated correctly with salesforce account. Your form fields are also mapped correctly with the salesforce contact fields. 

    Can you please confirm what type of account you have with salseforce? Have you added any custom field in your salesforce account?

    I would suggest you to re-integrate your form with salseforce and see if that helps you.

    We will wait for your response.

    Thank you!

    Asked by thechevra on February 04, 2015 at 11:26 AM

     

    Thanks so much to Jeanette for her response!  We followed the suggestion below, but unfortunately, there is still an issue.  Our longer form (an event application) is not making it into Salesforce.  Our shorter form (request for more info, which we created last night) was making it in to Salesforce, but then when we edited it to add a field (and then remapped/embedded), it no longer went to Salesforce either.  Is there a glitch?  Is the functionality just erratic?  Or is there something basic we're doing wrong?

     

    Answered by Jeanette on January 30, 2015 at 01:19 PM

     

    Have you updated the embedded code on your Wix Site? I would suggest you to clone your working form to avoid messing with it, then after updating or enhancing the form, create a new integrate with salesforce and grab a fresh code to embed it in wix site.

    Asked by thechevra on January 30, 2015 at 11:30 AM

    The export to Salesforce did work for previous versions of our event application, but it doesn't work for the most updated version.  Could you please let me know how to fix this?  Thanks so much!

     

     

     

    contact forms Wix SalesForce sending info
  • Profile Image
    JotForm Support

    Answered by Welvin on February 05, 2015 at 04:11 AM

    Hi, please find my answers below;

     

    We have the Enterprise edition for Salesforce

    -Our current Salesforce Integration requires Enterprise Edition or Unlimited-Type Packages.

     

    Yes, we have plenty of custom Salesforce fields -- but since they show up as mapping options, could that even be a possible source of the problem?

    -For as long as the field matches in Jotform field, there should be no problem in the integration. When I say matches, make sure that if your Salesforce field is a Textbox, you are also using Textbox in Jotform.

     

    We have re-integrated the forms, but unfortunately, that doesn't seem to be helping (other than the fact that occasionally it does properly export to Salesforce following an re-integration, but usually not.  

    -We only advise redoing the whole integration when making changes to the form or if the integration had stopped from working for some reason. 

     

    And unfortunately, it seems that every time we need to make even one field change, we then have to remap and reintegrate, which usually leads to a non-working integration)

    -If the integration is already present, we do not recommend making changes to both the fields in Jotform and in Salesforce. Otherwise, that would create a problem in syncing the data. If you need do it and if the integration will stop, then you will have to redo the whole integration process. 

     

    By the way, we have had our Salesforce Enterprise account customized with functionality that I believe is part of the Non-Profit Starters Pack (I'm mentioning this factor in case it might be contributing to the problem)

    -I'm not sure if that will cause the problem (I doubt it), but can you try reverting that changes to its original settings? 

     

    Is there a way we can speak on the phone about this (and should I respond with my #, or would you like to perhaps provide yours)?

    -Unfortunately, we don't provide a support over the phone. Please use this support forum instead.

     

    Is there a way I can respond directly to a thread (rather than re-posting everything anew each time)?

    -Yes, please! We advise users to reply to the same thread instead of creating a new one. This will help us to further troubleshoot the case and fix it eventually. This is the thread link: https://www.jotform.com/answers/510247. Click this or when you receive our reply in your email, click "View this thread on Browser":

     

    Thank you very much!

     

  • Profile Image

    Answered by thechevra on February 06, 2015 at 04:44 PM

    Thank you so much!  Your advice worked!!

  • Profile Image

    Answered by Ben on February 06, 2015 at 05:39 PM

    That is great to hear.

    I would just like to confirm that the issue was with the type of the fields, or by some chance with Non-Profit Starters Pack?

    If you do not mind updating us so anyone else finding this thread can find the answer to their problem as well.

    Thank you.

  • Profile Image

    Answered by thechevra on February 08, 2015 at 01:22 AM

    Sure!  It was the following advice that Welvin had responded with:

    "When I say matches, make sure that if your Salesforce field is a Textbox, you are also using Textbox in Jotform."

    In Salesforce, I had created a "lookup" field called "Campaign", and I had mapped that with a dropdown field in JotForm.  I then removed this mapping, and the integration worked.

    In reality, I would of course like to figure out how to still properly have applicants indicate the event name in JotForm so that it could come right in to a Salesforce campaign.  So while I at least figured out the problem (and was able to solve the integration by removing the source of the problem), I'd still like to solve the problem while maintaining a viable mapping option for "Campaigns".  Thanks!

     

  • Profile Image
    JotForm Support

    Answered by Welvin on February 08, 2015 at 07:01 AM

    You mean the following types, right?

    So you're saying it's a custom field?

    It's a kind of a search field with a textbox property so maybe you can map it with our Textbox field? How about trying that? Simply clone the original form and integrate the cloned version into Salesforce. Use a clone version so you won't be breaking the integration in the original form.

    Or, maybe you can also use our Auto complete widget: http://widgets.jotform.com/widget/autocomp.

    I would personally like to try it, but it seems I have a problem getting my Salesforce Security Token. I appreciate if you can try that and update us here.

    Thanks

  • Profile Image
    JotForm Support

    Answered by Welvin on February 24, 2015 at 03:20 PM

    We will look at that issue, but I would suggest accessing this thread and make sure to logged in before posting your reply. This is the thread: http://www.jotform.com/answers/510247. I will have to move the other issue into a new thread, but I can't do that because your username or account doesn't appear in your last reply.

    Or, you can post a new thread: http://www.jotform.com/answers/answer.php? and link it up here.

    Thank you and I look forward to your reply.

    Regards

  • Profile Image

    Answered by thechevra on February 24, 2015 at 08:48 PM

    Hi - I've logged in and I'm posting the following again:

    Hi -

    While most of our applications are making it in to Salesforce, a few of them are not.  In other words, the integration is working in general, but I occasionally get email notifications for application forms that I don't end up finding in Salesforce.  Any thoughts?
  • Profile Image
    JotForm Support

    Answered by ashwin_d on February 25, 2015 at 05:36 AM

    Hello thechevra,

    I have moved your question to a new thread and you will be answered here:  http://www.jotform.com/answers/522250 

    Thank you!

  • Profile Image
    JotForm Support

    Answered by NeilVicente on July 06, 2016 at 07:44 AM

    Hi,

    Sorry for the late update, but we'd like to inform you that this is now available. You may now specify the campaign ID in the Salesforce integration wizard to add a newly-created record to a campaign.

    Let us know if you have other questions or concerns.

     

    Best,