What is JotForm?
JotForm is a free online form builder which helps you create online forms without writing a single line of code. No sign-up required.

At JotForm, we want to make sure that you’re getting the online form builder help that you need. Our friendly customer support team is available 24/7.

We believe that if one user has a question, there could be more users who may have the same question. This is why many of our support forum threads are public and available to be searched and viewed. If you’d like help immediately, feel free to search for a similar question, or submit your question or concern.


  • Profile Image

    Unable to download PDF reports with custom data range

    Asked by LyndaAbel on March 06, 2015 at 08:32 AM

    Trying to download yesterday's submission to pdf using Custom Date preference...system clocks, and then error is displayed:

     

    downlonad pdf custom range report report filter report download PDF report
  • Profile Image

    Answered by Sean on March 06, 2015 at 10:53 AM

    I checked your account and I did a test report download for the pre-set custom date (2015-03-01 - 2015-03-01) that you have and it worked just fine. Can you give this another try and let us know the out?

    Perhaps clearing your browser cache might help? Please advise.


    Thank you

  • Profile Image

    Answered by LyndaAbel on March 06, 2015 at 01:59 PM

    Hi - I had tried to include a screen grab on my initial question but it didn't post.

    It seems that the date range of 2015-03-01 to 2015-03-01 is the only range that does work; each subsequent day hangs the system, eventually resulting in the error message:

    "Downloading submissions between null and 20 failed" ; Retry

    I've cleared cache and retested multiple times; same result for any day other than 3/1 (which was our first day of submissions).  We were able to run 3/2, 3/3, and 3/4 prior to today.  Error first appeared when running for 3/5 this morning. 

    We run daily (would love to see the timestamp added to the Custom Range so that we could run hourly...but for now we are running daily).

    Any other suggestions?  Can you test our account for these other dates?  Thanks!

     

  • Profile Image

    Answered by Sean on March 06, 2015 at 03:36 PM

    I did another download test using your form and I tried 3/5 to 3/5 and it download just fine as well.



    Can you say which browser you are using? Did you try using another browser to see if the outcome would be any different. I am using Google Chrome.

    As for your feature request, I have transferred it to a different thread were it will be addressed separately. You can view it here: http://www.jotform.com/answers/528434 

  • Profile Image

    Answered by LyndaAbel on March 06, 2015 at 04:38 PM

    Hmm.. I've tried IE, Firefox, and Chrome and it hangs on all...even for today's submissions (we submitted a test registration to be sure that the front end is working and it seems fine; submission is received and confirmation email is sent).

    Do you have the ability to webex to my pc?  I'm here until 5:00 est.  I can send my phone number if you provide an email...

  • Profile Image

    Answered by Sean on March 06, 2015 at 05:59 PM

    Unfortunately, we are not able to use any other methods other that Forum, Chat or Email to provide support at this time. So we have to see how best we can address the issue through this medium.

    Is it possible for you to try another PC? Are you sure there aren't any restrictions on your account that could be causing this?

  • Profile Image

    Answered by LyndaAbel on March 07, 2015 at 12:47 PM

    I'm looking at your post from yesterday, and see that you are using the individual pdf feature.  That's not the problem.

    We are not able to export the entire day's worth, using the 'Download as Excel  CSV  PDF' toolbar on the bottom half of the screen.  The Excel and CSV work fine.  The PDF still not working (I'm now testing on a MacBook Pro on Safari from home.  Yesterday on a PC on the 3 browsers listed above from office.).  3/1/15 works but no other date is working.

    Still get 'Downloading Submissions between null and 20 failed' message after the system clocks for a minute or 2 with the 'generating' message in the toolbar area.

    When this feature does work (for 3/1), the message displayed is the popup box:

    "Download PDF

    You have 103 submissions 

    Since you have over 20 submission, they will be downloaded by 20…"

    and then we download in batches.

    Help!  Thanks!

     

     

     

  • Profile Image

    Answered by Sean on March 07, 2015 at 02:34 PM

    Thank you for the update.

    I tried the PDF report link right above the data grid and I was able to replicate the issue. 



    This error message was displayed after while.



    I will pass this information on to our development team so that they can have it addressed. In the meantime, I would recommend using the Excel/CSV report as an alternative until this issue is being resolved. Hopefully that will not cause too much of an hassle for you. 

    Once our team completes the necessary test and corrects the issue, you will be updated via this thread.

    Thank you

  • Profile Image

    Answered by LyndaAbel on March 09, 2015 at 08:43 AM

    I see that other clients are now reporting this same problem.  Any progress? 

    I just attempted, and still get the same error.

    Thanks.

  • Profile Image
    JotForm Support

    Answered by Charlie on March 09, 2015 at 10:48 AM

    Hi,

    Unfortunately, upon testing in my end the problem still seems to persist. However, I see that the issue has already been escalated to one of our developers and currently looking at it now, it is marked as "Urgent" in our priority list. We will hear news directly from them when the problem has been fixed.

    Apologies for the inconvenience and thank you for your patience and understanding.

  • Profile Image
    JotForm Support

    Answered by alp_deniz on March 09, 2015 at 12:18 PM

    Hello,

    We have fixed relevant download problems. Could you please confirm if the problem is completely fixed?

    Thanks

  • Profile Image

    Answered by LyndaAbel on March 09, 2015 at 01:57 PM

    Sorry, still not working.  Here's the test from 1:50pm ish today:

  • Profile Image

    Answered by LyndaAbel on March 09, 2015 at 01:58 PM

    The screen grab didn't post: same problem as described earlier using today's date.

  • Profile Image

    Answered by Ben on March 09, 2015 at 02:44 PM

    I hope that you will not mind me asking you to try again since our developers had released the last patch to the system recently that should make it work for you.

    Now when you test this if you get any error and you have a screenshot, please upload it to the thread following the steps shown here: How to add screenshots/images to questions in support forum?

    Please note that if you add them over email, they will not be captured nor shown by our forum.

    Please do let us know how it goes. Thank you.

  • Profile Image

    Answered by LyndaAbel on March 09, 2015 at 02:51 PM

    Still not working.  Here's the screen grab that I uploaded from the latest test (2:50pm ish)- same scenario as before:

  • Profile Image

    Answered by Ben on March 09, 2015 at 03:21 PM

    OK, thank you for the confirmation.

    I took a look at this jotform: http://www.jotformpro.com/form/50535679949978 and its submissions and I was able to recreate the issue:

    Fortunately as I was able to get the same error, I was also able to see some of the potential issues which I will send to our developer for inspection so that we can resolve this for you.

    In the mean time I apologize for the inconvenience.

  • Profile Image
    JotForm Support

    Answered by alp_deniz on March 09, 2015 at 11:39 PM

    Hi,

    We have just been able to detect and resolve the issue thanks to your clear description of the problem. It should now work perfectly.

    Thank you very much. Your help is very much appreciated.

    Kind regards

  • Profile Image

    Answered by Ben on March 10, 2015 at 09:55 AM

    I see that you have posted or sent an email with this content:

    "Yes, it is now working.  Thanks so much!"

    I am posting it here since it does not seem to be shown on our forum.

    We are however glad that it is now working for you. Do enjoy your time with our JotForm Builder and let us know if we can be of any assistance to you.

  • Profile Image

    Answered by ECYMCA on April 02, 2015 at 01:16 PM

    Hi,

    I am getting the same error as shown above. http://www.jotform.us/form/50274693196160

     

  • Profile Image

    Answered by Ben on April 02, 2015 at 02:35 PM

    @ECYMCA I see that you have already opened a thread for this here: https://www.jotform.com/answers/545535 and that you have included screenshots about the error.

    We will be replying to you on that thread shortly.