What is JotForm?
JotForm is a free online form builder which helps you create online forms without writing a single line of code. No sign-up required.

At JotForm, we want to make sure that you’re getting the online form builder help that you need. Our friendly customer support team is available 24/7.

We believe that if one user has a question, there could be more users who may have the same question. This is why many of our support forum threads are public and available to be searched and viewed. If you’d like help immediately, feel free to search for a similar question, or submit your question or concern.


  • Profile Image

    Dynamic Dropdowns widget causes the form to not allow submission

    Asked by cleanarc on March 06, 2015 at 09:11 AM

    Hi,

    I need some help very quickly as my client's site goes live this weekend. The following form: https://secure.jotform.us/cleanarc/Kids_First_for_Parents, works great until you get to the payment section and hit submit. The submit button changes to "Please Wait" and nothing ever happens after that. We are using the Authorize.net payment widget, and have the set up the proper Transaction ID, and Key as well as have confirmed them via the integration process. Do you have any insight as to what might be happening here?

    Thanks

    John Harrison

     

    Page URL:
    https://secure.jotform.us/cleanarc/Kids_First_for_Parents

    after please wait section Dynamic Dropdowns
  • Profile Image

    Answered by cleanarc on March 06, 2015 at 09:17 AM

    Actually looking over the help requests it seems that this happening to a lot of people.  This might be something other than a browser cache issue guys.  

  • Profile Image

    Answered by raul on March 06, 2015 at 11:30 AM

    I've made a test using a cloned version of your form and was unable to reproduce the issue.
    The form was submitted correctly and the payment went trough using a test credit card.

    I've cleared your form's cache to see if it helps.

    Please give it another try and let us know if the issue persists.
    You can also try using the sandbox mode of authorize.net to make further tests.

    Thank you.

  • Profile Image

    Answered by cleanarc on March 06, 2015 at 05:33 PM

    Hi,

    The issue persists. I even cloned it and then tried it and got the same result. Hangs up after the submit button.  I cleared the cahce in all my browsers, shut of https to see that was an issue. Nothing I try seems to solve the problem.  Please help, the site is to go live in the AM!!

  • Profile Image

    Answered by cleanarc on March 06, 2015 at 05:41 PM

    Hi again,

    I just tested another form on the site:  https://secure.jotform.us/cleanarc/Evening_Workshops

    and its happening with this form as well. The one things these two forms have in common is Authorize.net.  Let me know if this information is helpful.  We have to solve this tonight.

    Hope you guys are around.

  • Profile Image
    JotForm Support

    Answered by Kiran on March 06, 2015 at 07:50 PM

    Hello John, 

    As I test the JotForms with the cloned version, I was not able to replicate the issue. When I tried to submit your live version, I was able to get the error stating that the transaction has been declined since I was using a test credit card. Could you confirm if the issue appears after embedding the JotForm on your webpage? If so, please provide us with the URL so that we can investigate the issue further.

    Thank you!

  • Profile Image

    Answered by cleanarc on March 06, 2015 at 08:23 PM

    Hi,

    So did what you asked. Embeded the form on the site at this link: http://kidsfirst.previewmedia.us/test-kids-first-reg-page.html. Still had the same problem.

    Hangs up on the submit button saying "please wait"

  • Profile Image
    JotForm Support

    Answered by Kiran on March 06, 2015 at 09:04 PM

    It seems there is a conflict with the scripts on your website. We can see that the conditions are not working here.

    Please try embedding the JotForm using iframe method instead of normal JavaScript method. The following guide can help you in getting the iframe code for your JotForm.

    http://www.jotform.com/help/148-Getting-the-Form-iFrame-Code

    If the issue still persists, please enable sandbox mode on the payment field and let us know so that we can run test transactions which helps in investigating the issue further.

     

    Thank you!

  • Profile Image

    Answered by cleanarc on March 06, 2015 at 09:13 PM

    Okay...that did not work either.  I will work to enable the sandbox.

  • Profile Image

    Answered by Ben on March 07, 2015 at 05:45 AM

    There are 2 issues with the jotform:

    1. The background image is loaded over HTTP while on secure version (it should have done so over HTTPS)

    Fixed that on this jotform: https://secure.jotformpro.com/form/50652895410961 and would like to ask you to clone it to your account and set the Authorize.net and try to see if you get the same error or not.

    2. The Dynamic DropDowns widget is causing the value to not be sent to Authorize.net widget.

    I presume that this might be the case since if you do not make any selections on the second page (the field is not required) then the dynamic dropdowns are not shown and no value is being passed over.

    I made a change on them as well and the same form as above holds the change so please let us know how it goes.

    If there are still some errors shown let us know and we will raise it to our developers to inspect the Dynamic Dropdowns widgets, while I would suggest using regular dropdowns instead on your jotform.

  • Profile Image

    Answered by Ben on March 07, 2015 at 05:55 AM

    I have just made a few more tests to confirm and will raise this to our developers.

    The issue is caused by Dynamic DropDowns widget so I would suggest cloning the current jotform (please clone mine above since the issue with image is fixed in it) and leaving the current one as it is.

    Then on that new clone to add regular dropdown instead.

    Our developers will take a look at your current jotform to see exactly why this happens and will update you through the thread as soon as there are any news about it.

    Thank you.

  • Profile Image
    JotForm Support

    Answered by TitusN on April 08, 2015 at 09:05 AM

    Hello, 

    Sorry for the long wait - we've updated the widget - and you should not be experiencing the submit hangup. 

    The Dynamic Dropdowns script that was causing this has been fixed. 

    Please check and let us know.