What is JotForm?
JotForm is a free online form builder which helps you create online forms without writing a single line of code. No sign-up required.

At JotForm, we want to make sure that you’re getting the online form builder help that you need. Our friendly customer support team is available 24/7.

We believe that if one user has a question, there could be more users who may have the same question. This is why many of our support forum threads are public and available to be searched and viewed. If you’d like help immediately, feel free to search for a similar question, or submit your question or concern.


  • Profile Image

    form taking to long to load and no data

    Asked by tentenaerials on March 12, 2015 at 06:55 PM

    Hello I have a form with option to buy 2  multiple items preview all ok when on line takes 20 seconds to load the  form and when tick box placed in item no price appears and captca does not load until refreshed 

     

    at moment totally unusable

     

    I have other basic contact forms that load without issues

     

    can you please help

    and no data Taking Long
  • Profile Image
    JotForm Support

    Answered by BDAVID on March 12, 2015 at 08:02 PM

    Based on your last form edit, I assume you are referring to this form: http://www.jotformpro.com/form/50584940780966, which in it's standalone version loads fine, no delay presented.

    If the forms presents loading delays even in it's standalone version(http://www.jotformpro.com/form/50584940780966) in your end, it might be due to browsers cache issues, I would suggest you clearing caches, or tried in other browsers to see if the delay occurs. 

    If the issue happens on your embedded form, could you please share the URL of the webpage where that form is embedded? So we can see how it is behaving there.

    In the mean time, I was inspecting your form preferences, I see you have enabled the Auto Fill option: 

    Please be noted that when you enable the auto fill settings, it actually writes the input data in browser cookie every few seconds and that could be a reason of this delay, just tried disabling to discard this possible reason.