MailChimp integration does not allow the fields to be mapped properly by showing several entries multiple times

  • Profile Image
    YZYkithomes
    Asked on March 14, 2015 at 10:23 PM

    Hi

    Although I have a Full Name from Quick Tools, MailChimp would not capture the field to assign for name. 

    Pls help

  • Profile Image
    Ben
    Answered on March 15, 2015 at 12:58 AM

    I took a look at your jotform, but it does not seem to be working properly.

    I have tried integrating with my MailChimp list, but it found the name field straight away without me needing to select it, but with your it did not.

    Now another strange thing is the list, I can only see one field with such label on your jotform,

    yet 4 are listed on the mapping fields screen.

    I get the same listing on my clone of your jotform as well.

    Now, I am trying to create the same issue on my other forms, but they seem to list the options properly and to connect to my mailchimp list properly.

    Could you please take a screenshot of the mailchimp list for us so that we can see how you set it and see what would be expected to be sent for the name field, while I will raise this issue with the multiple options showing the same title.

    It might be that one of those options is the name field, it is just not showing up properly, but once we see how the list is created and our developers take a look at the issue we would know more.

  • Profile Image
    Jeanette
    Answered on March 15, 2015 at 01:47 PM

    -Please delete the current Mailchimp integration

    -Then generate a new API key on your mailchimp account

    -And rebuild the integration with your form

  • Profile Image
    Jeanette
    Answered on March 15, 2015 at 01:50 PM

    Another solution would be to make a clone of the form and follow the steps I indicated before.

  • Profile Image
    YZYkithomes
    Answered on March 15, 2015 at 08:03 PM

    Thanks Ben Jeanette,

    Ben, I see the same multiple options showing the same title

    Jeanette, I tried to follow your steps, but the result was the same unfortunately.. have not tried to clone the form but Ben did it so probably not going to work..

  • Profile Image
    YZYkithomes
    Answered on March 15, 2015 at 08:10 PM

    Just tried to integrate MailChimp to my other form, exactly the same case: multiple options showing the same name and there are no full name.

    Ben, screenshot is in my first post, it looks the same as yours. Let me know if I can do anything else to help. 

  • Profile Image
    KadeJM
    Answered on March 16, 2015 at 09:58 AM

    It is a bit odd that the Full Name isn't mapping on your end. I did a test of this on my end and unfortunately I'm not able to replicate this issue. If there happens to be any problem then I think it is possibly with your mapped fields or api key and if not then it is an issue on your account.

     

    What Merger Fields do you have listed in your MailChimp Account for the List that you are trying to integrate your form with? Perhaps you've relabled or deleted the name field.

    Are you able to show us a screenshot of what you have on your end for those fields or at least doublecheck them on your end to see what you have since its still not showing the map for you?

     

    You could alternatively just use one textbox as your Name Field and relabel it so that it is mapped to a singular field in MC of the same for text. 

     

  • Profile Image
    YZYkithomes
    Answered on March 16, 2015 at 11:56 PM
    Thanks KadeJM, pls see the Merger Fields listed in my MailChimp Account for the List below.
    I tried to change the API key, did not work. All my forms behave the same, not populating the FullName field to MC.. It must be something with my account then? 

    Inline image 1
     
     
  • Profile Image
    Welvin
    Answered on March 17, 2015 at 06:30 AM

    Unfortunately, this support forum cannot accept inline image attachments. Please upload the image to this support forum instead. We have this guide: http://www.jotform.com/answers/277033.

    As for the issue, try to create a new list in your MailChimp Account and use the default form of this list, don't change anything in the form. Try to integrate it with your current jotform and see if the Full Name field will appear in the integration. If not, then I think the issue is in your account merge tags.

    Thank you and we look forward to your reply!