What is JotForm?
JotForm is a free online form builder which helps you create online forms without writing a single line of code. No sign-up required.

At JotForm, we want to make sure that you’re getting the online form builder help that you need. Our friendly customer support team is available 24/7.

We believe that if one user has a question, there could be more users who may have the same question. This is why many of our support forum threads are public and available to be searched and viewed. If you’d like help immediately, feel free to search for a similar question, or submit your question or concern.


  • Profile Image

    The submissions page does not work

    Asked by pngrover on April 17, 2010 at 11:14 AM


    I need to download my reports in excel format as I was able to do easily before. I read your statement that we could go to the submissions page (right there it's weird- it was a report before) and click on the excel button, but I only get a big gray empty box with nothing else on the page. I have tried refresh, going all the way out and back in, and get the same error.

     

    We are having a very large Earth Day event tomorrow, and I need those excel reports.

  • Profile Image
    JotForm Founder

    Answered by aytekin on April 17, 2010 at 11:37 AM
    That's what happens where there are no submissions. Are you sure you selected the correct form on My Forms page before clicking on the Submissions button?
  • Profile Image

    Answered by pngrover on April 17, 2010 at 11:46 AM

    yes, there are submission, and yes, i selected the right form.
  • Profile Image

    Answered by billwww on April 17, 2010 at 07:01 PM
    I have the same problem.    I usually use IE8.
    But just to check - if I use Firefox,  the submissions page works great.  Better than expected.

  • Profile Image

    Answered by donyahw on April 18, 2010 at 01:39 PM

    I think it has something to do with IE8 because if I use Google Chrome it works just fine!!
  • Profile Image
    JotForm Founder

    Answered by aytekin on April 19, 2010 at 10:37 AM
    This problem on IE should now be fixed.