What is JotForm?
JotForm is a free online form builder which helps you create online forms without writing a single line of code. No sign-up required.

At JotForm, we want to make sure that you’re getting the online form builder help that you need. Our friendly customer support team is available 24/7.

We believe that if one user has a question, there could be more users who may have the same question. This is why many of our support forum threads are public and available to be searched and viewed. If you’d like help immediately, feel free to search for a similar question, or submit your question or concern.


  • Profile Image

    Form Designer just keeps on loading and not opening

    Asked by Jonas170 on April 10, 2015 at 05:30 AM

    When I click on the button, the loading pages opens, but it load and load ... and load. The Disigner does not load and open. What can I do?

    form designer does not work designer work keeps on loading not opening
  • Profile Image

    Answered by Syed on April 10, 2015 at 09:09 AM

    Hi there;

               Please try to remove your Web Browser's Cache & Cookies, and let us me know if you have questions/queries, we would be happy to assist you.

     

    Thankyou,

    - Syed

  • Profile Image

    Answered by Jonas170 on April 10, 2015 at 05:32 PM

    Thank you for your answer. I tried it, but it doesn´t work :/

  • Profile Image
    JotForm Support

    Answered by Jan on April 10, 2015 at 07:06 PM

    Hi there,

    The Form Designer tool is working on my end. I've tested it with Chrome, Firefox and Internet Explorer 11.

    Can you please try loading the Form Designer using another browser? So we can check if it is a browser issue. 

    Also, please try to edit another form or create a new form. This is to check if the problem only happens on that form.

    Thank you.

  • Profile Image

    Answered by Jonas170 on April 10, 2015 at 07:39 PM

    I tried it on InternetExplorer Chrome and Friefox, too but it still doesn´t work ... also on other forms

  • Profile Image
    JotForm Support

    Answered by Jan on April 10, 2015 at 09:16 PM

    Can you please share a screenshot where would the form freezes?

    I tried logging in to your account and I was able to go to the Form Designer, though it takes a while because the background image is loading.

    I will now clear your form cache, so that it will be refreshed from our servers. Please try the following again:

    1. Log out from JotForm.

    2. Clear your browser cache.

    3. Close and re-open the browser.

    4. Log back in to JotForm.

    5. Try the form designer again.

    Do you have another computer to try on? If it works on another computer then it could be a ISP problem.

     

    Hope this works. Thank you.

  • Profile Image

    Answered by BWSites on April 10, 2015 at 09:43 PM

    I used to have loads of trouble with things like this when I had satellite service (Hughsnet) and ATT 3G

    Since I switched to cable (3 times the speed) I have very very few problems..just saying, internet connection makes all the difference.

  • Profile Image

    Answered by Jonas170 on April 11, 2015 at 04:32 PM

    I tried to Clear all but it it is still frozen. On an other Computer in my Network it works but on my Laptop it looks bad.

     

  • Profile Image

    Answered by raul on April 11, 2015 at 08:06 PM

    Can you please try to use the following URL to load the designer: https://www.jotformeu.com//?formID=50744692667366#design while you're logged into your account?

    Let us know if this makes any difference.

     

  • Profile Image

    Answered by Jonas170 on April 12, 2015 at 04:37 AM

    That URL works !!

  • Profile Image

    Answered by Syed on April 12, 2015 at 06:34 AM

    In behalf of my colleague, please let us know, if you need further assistance, we would be happy to assist you in any way.

     

    Thankyou.

  • Profile Image

    Answered by Jonas170 on April 12, 2015 at 07:02 AM

    Thank you for your help. What was the problem?

  • Profile Image

    Answered by Syed on April 12, 2015 at 07:04 AM

    I believe it was Browser's Cache issue, that's why it is accepting the Direct Link and not Relative Link.

     

    Thanks!