What is JotForm?
JotForm is a free online form builder which helps you create online forms without writing a single line of code. No sign-up required.

At JotForm, we want to make sure that you’re getting the online form builder help that you need. Our friendly customer support team is available 24/7.

We believe that if one user has a question, there could be more users who may have the same question. This is why many of our support forum threads are public and available to be searched and viewed. If you’d like help immediately, feel free to search for a similar question, or submit your question or concern.


  • Profile Image

    why does my form jumps to the top when i click next?

    Asked by cbtcollege on November 08, 2011 at 06:34 PM

    On IE, my browser auto scrolls slightly down the page after I hit next.

    http://degrees.cbt.edu/ 

     

    Page URL:
    http://degrees.cbt.edu/

  • Profile Image
    JotForm Support

    Answered by Mike_T on November 08, 2011 at 07:00 PM

    We are sorry for the inconveniences caused.

    Could you please try to embed your form using iFrame option to see if that makes any difference?

    We are looking forward to hearing from you.

  • Profile Image

    Answered by cbtcollege on November 09, 2011 at 09:45 AM

    Unfortunatly, I still have the same problem and I noticed it also happens in Firefox. Is there any other posible way to fix it?

  • Profile Image

    Answered by allanftd on November 09, 2011 at 03:43 PM

    Hi cbtcollege,

    Please add the following to the URL of your form:

    ?nojump

    so that your form's URL becomes http://www.jotform.com/form/12345678910?nojump . take note also of the structure of the URL. If you want the form to be secure, please use https://www.jotform.com/form/12345678910?nojump

    Please try and let us know how it goes. Thank you for using JotForm!

    Allan
    JOTFORM SUPPORT

     

  • Profile Image

    Answered by cbtcollege on November 09, 2011 at 06:03 PM

    I still have the same issue... would it make any difference if I try a different embedding options? 

  • Profile Image

    Answered by fxr on November 09, 2011 at 07:56 PM

    Try changing the iframe embed from:

    <iframe allowtransparency="true" src="//form.jotform.com/form/12974705753?nojump" frameborder="0" style="width:100%; height:936px; border:none;" scrolling="no">

    to

    <iframe allowtransparency="true" src="//www.jotform.com/form/12974705753?nojump" frameborder="0" style="width:100%; height:936px; border:none;" scrolling="no">

    If that 2nd one doent work try this script embed 

    <script type="text/javascript" src="//www.jotform.com/jsform/12974705753?nojump"></script>

    Please make sure to clear your browser cache after every change, its very easy for you browser to cache an earlier version of your code. 

    It should work.

  • Profile Image

    Answered by cbtcollege on November 10, 2011 at 09:47 AM

    I have tried both codes, but the problem persist. I cleared my cache as suggest too with no good results, is there any other thing I can do?
    You are more than welcome to check my code by visiting the website. 

    Thank you.

  • Profile Image

    Answered by fxr on November 10, 2011 at 03:27 PM

    I will pass this on to the developers and ask if this ?nojump feature is still working. 

    This is a common issue with any iframes embedded into a webpage, there is workarounds out there but I cant really do much with the code in this instance because the form is on a different domain, meaning I cant access the parent windows controls to reset the browsers position. 

    I will continue to try and think of some kind of solution.

  • Profile Image

    Answered by emrew86 on November 11, 2011 at 07:17 AM

    Hi cbtcollege, bug has been fixed. Can you test it again please ?

  • Profile Image

    Answered by cbtcollege on November 11, 2011 at 09:20 AM

    Awesome! It works perfectly fine now!

    Thank you very much! 

  • Profile Image

    Answered by webgroup on December 14, 2011 at 06:43 AM

    I need to add the ?nojump as above - but I already have one called ?Item=<?= $product->name ?> - which drags the product title to the email hidden form.

    How can I have both:  
    ?nojump and 
    ?Item=<?= $product->name ?>

    ?????

    Thanks

     

  • Profile Image
    JotForm Support

    Answered by liyam on December 14, 2011 at 08:22 AM

    You can try doing something like ?nojump&Item=<?= $product->name ?>

    Please keep us posted with the result.

    Thanks.

  • Profile Image

    Answered by webgroup on December 14, 2011 at 08:45 AM

    It no longer auto poplates the field?

  • Profile Image
    JotForm Support

    Answered by liyam on December 14, 2011 at 08:51 AM

    Can you please share to us the URL of this web page?

  • Profile Image

    Answered by webgroup on December 14, 2011 at 08:57 AM

    I can't share the URL here because the site is in development but can you see the issue I'm having in a locked post with one of your guys "fxr" - can you see that post?

  • Profile Image
    JotForm Support

    Answered by liyam on December 14, 2011 at 10:03 AM

    I see.. sorry.. try to switch the places of the two.

    So instead of this: ?nojump&Item=<?= $product->name ?>

    Use this: ?Item=<?= $product->name ?>&nojump

  • Profile Image

    Answered by webgroup on December 14, 2011 at 10:16 AM

    Nope - makes no difference.

    I think the issue is with JotForm as this was working earlier before I started to add the nojump. If I completly remove the nojump (and put it back to the way it was when it was working ok) it still fails.

    Would I be better to scrap this form and start again?

     

  • Profile Image

    Answered by fxr on December 14, 2011 at 10:50 AM

    Hi webgroup.,

    I wouldn't scrap the form and start over, you have just been attempting to feed it parameters, the form itself hasnt been touched. You won't have 'broken' it.

    I would really appreciate you opening a new thread for this ?nojump issue and give as much detail of how far along you are as possible.

    Its much easier from a support point of view if our users open a new thread for each seperate issue they have. 

    I will be able spend some time looking at the issue for you this evening. 

    Thanks!

  • Profile Image
    JotForm Support

    Answered by liyam on December 14, 2011 at 12:57 PM

    Also, please make sure that you visited the page properly and not just refreshed the browser.  Sometimes you will need to like enter the URL and submit rather than just pressing f5 to make sure that the page has the properly updated contents.  As I tried my last suggestion I was able to somehow make it work.