Form not submitting when embedded in muse site

  • Profile Image
    ElizabethWM
    Asked on April 27, 2015 at 02:56 PM

    Hi, I built my first form with jot form  - I am working on upgrading my website to HIPAA compliance so need you secure services, I have to re-do all of the forms on my site. I will be upgrading to a paid subscription as soon as I get these details worked out, ensuring that I can use your services for my needs. 

    I built the form, and it was working well in preview mode. When I submit from there it takes me straight to paypal as it should.

    When I embed the form using the "Insert HTML" feature, and upload the page it won't submit. I complete it, hit submit, and an error message flashes in red at the button very briefly, even though all of the fields are completed. It doesn't turn me over to PayPal as it should. 

    Is this a known issue? Can you tell me how to fix it? 

    Thanks, 

    -Elizabeth

  • Profile Image
    ElizabethWM
    Answered on April 27, 2015 at 03:56 PM

    I solved the problem.

    I saw that the submissions were appearing in the form's records in the JotForm platform as "pending" because payment wasn't completed, so I tried changing the embedded HTML to Iframe using the code generator in the form creation dialogue and it worked. 

  • Profile Image
    david
    Answered on April 27, 2015 at 05:00 PM

    Hi,

    I am glad to hear you were able to get thing sorted.  Usually the iFrame embed method is the go to solution when it comes to getting forms to embed properly.  If you have any further questions, let us know and we will be happy to help.