My form was able to submit without a required field completed.

  • Profile Image
    Asked on May 18, 2015 at 12:55 AM


    Our third live submission was able to submit without a completed required field.  Please see the link for the screen capture of the notification email.

    I tried to submit the form without the "Date of Event" field completed, and the the form would not submit until I had filled in that date.

    Is there a simple explanation for this?


    Thank you



  • Profile Image
    Answered on May 18, 2015 at 04:54 AM


    I fixed your problem about empty fields.

    Please re-check it and let us know. 

    Best Regards.


  • Profile Image
    Answered on May 18, 2015 at 12:15 PM

    Thank you, I tested and with the Required Field empty, the form would not submit.  The problem now is that if the field is empty and I click Submit, there is no warning at the bottom of the form that I need to go back and fill-in a field.  Now, nothing happens when I click Submit.  I have to scroll up and see what I did wrong.  For my group, it is better to have the warning at the bottom of the form so that they know to go back and fill in the required field.


    Can you add the warning at the bottom of the screen?  So they know something is wrong.


    A new problem is that the Google Spreadsheet is not capturing the Submission Time-stamp for the last two submissions.  Can you please advise on that too?


    Thank you.  sw

  • Profile Image
    Answered on May 18, 2015 at 01:07 PM

    Hello mbycsd,

    I did check your web page where you have embedded your form and there seems to be some issue. It is not displaying validation error message for all the form fields and the captcha is also not loading correctly most of the time. Please check the screenshot below:


    This issue happens when there is a code conflict between your form and other script available in your web page. I would suggest you to embed your form using its iFrame embed code and that should resolve your issue. The following guide should help you in grabbing your form's iFrame embed code: 

    Hope this helps.

    Do try it out and get back to us if the issue persists.

    Thank you!

  • Profile Image
    Answered on May 18, 2015 at 02:30 PM

    Yes, I changed to the iFrame.  It looks like the Captcha is loading correctly now.  I am getting the "This field is required." notifications.

    thank you.


    I will create a new support ticket for my question about the Google spreadsheet no longer captures the submission time stamp.



  • Profile Image
    Answered on May 18, 2015 at 03:22 PM

    Glad to hear that using the iFrame method solved your issue.  We will follow up with any other threads you have created as soon as we get a chance.