What is JotForm?
JotForm is a free online form builder which helps you create online forms without writing a single line of code. No sign-up required.

At JotForm, we want to make sure that you’re getting the online form builder help that you need. Our friendly customer support team is available 24/7.

We believe that if one user has a question, there could be more users who may have the same question. This is why many of our support forum threads are public and available to be searched and viewed. If you’d like help immediately, feel free to search for a similar question, or submit your question or concern.


  • Profile Image

    Conditions: Show and hide logic not working properly

    Asked by cheekyface on June 01, 2015 at 06:22 AM

    Form: http://form.jotformpro.com/form/42831279630961?

     

    Hi.

    Just wondering why I'm having problems with a condition set on the button check boxes widget?  It's set to show a message upon the check box being filled but it doesn't work.
    I tried to delete and re-enter the logic and then it worked until I did some more editing to the form (elsewhere) then tried it again and it was back to the problem again.

    The field in question is at the very beginning and asks if the user wants to know more about how the form works?  if they click to read more then text appears below it.  Well that's how it's supposed to work.  At the moment it's not showing the button to click and the text is showing by default instead of being hidden.

    First I noticed this was when I tried to insert a preview before submitting form widget.  After that no matter what I did I couldn't fix it and it's a been a few days now.  
    I'm using Google chrome mostly. It's OK in firefox though.

    To add to that, after noticing this problem I tried to revert back to an older form but it didn't make any difference.  I've used this form for a long time and I'm 100% sure this is a new problem.

    Hope you can help soon.

    Cheers,

    Danny.

    Page URL:
    http://form.jotformpro.com/form/42831279630961?

    check problem hidden conditions show and hide
  • Profile Image
    JotForm Support

    Answered by Jan on June 01, 2015 at 10:25 AM

    I checked your direct form and it seems to be working in both Chrome and Firefox. The text are not showing when I view the form.

    Once I click the "Click to read". The text will show up.

    The "Get on with quote" button is also working properly. If the issue persist, please try clearing your browser cache. In addition to that, I will clear your form cache so that your forms will be refreshed from our servers. Thank you.

     

  • Profile Image

    Answered by cheekyface on June 02, 2015 at 02:43 AM

    Hi Jan.

    I can't imagine what the problem is then.  It's still the same at my end and I cleared the browser cache and history and everything for the past week.  Perahps it's another setting in chrome.  Any ideas what it might be?

    I can't do anything with the form except edit it although, I almost forgot to mention this, I'm not getting any email notifications all of a sudden.   Usually when someone responds to a support request that I've made I'll get an email notifying me and the same is set up in the form when someone completes it (which they did today).  In either case I did not receive any notification.  Could this have anything to do with Jotform?

    I'll check a little more thoroughly at my end.

    Here's a screen shot on my PC.  

  • Profile Image

    Answered by cheekyface on June 02, 2015 at 05:18 AM

    ...I've also reset chrome and still have the same issue.

  • Profile Image

    Answered by cheekyface on June 02, 2015 at 06:24 AM

    I'm actually beginning to think this has something to do with jotform or it's the internet here where I live but I can't verify it.  I just tried to open the same form on another computer and that was about 5 minutes ago and it's still loading.  All I have is the back i,age but no form.

    I also clicked to edit the form from my Forms page and it's still trying to load the editor.  I don't seem to be having any problems with other websites it's hard to see how it could be an issue here but I'm willing to try anything if you have any suggestions.

    Cheers,

    Danny.

  • Profile Image
    JotForm Support

    Answered by ashwin_d on June 02, 2015 at 08:56 AM

    Hello Danny,

    I'm sorry for the trouble caused to you. 

    I just have one question. The another system on which you tried to load/edit your form is also in the same network/LAN? If that is the case it could still be a cache related issue.

    Here are the steps, I would suggest your:

    #1. Sign out form your account.

    #2. Clear your browser cache. The following guide should help you clear browser cache:  http://www.wikihow.com/Clear-Your-Browser's-Cache 

    #3. Restart your internet router / modem.

    #4. Click on the following URL and then sign in to your account:  http://www.jotform.com/?noCDN=true 

    After you sign in to your JotForm account using the above URL, then you try to edit / load your forms and see if that solves your problem.

    Hope this helps.

    Do get back to us if the issue persists.

    Thank you!

  • Profile Image

    Answered by Danny on June 02, 2015 at 09:00 PM

    I've followed the steps above but it won't let me log in using that link http://www.jotform.com/?noCDN=true 

    It opens up to the form editor then all I see is text telling me to wait then it finishes by saying "I give up".  When I try to login there is no response from clicking on the buttons.

  • Profile Image

    Answered by cheekyface on June 02, 2015 at 09:05 PM

    So I was shown a window to enter my password and log-in when I submitted the previous comment (By Danny).  So I guess I've now been logged in...

    Still no difference - the form is the same.

    I'm going to try to re-install chrome and see if that fixes it.  In my last comment I should have included that before I encountered this issue I had the same thing happen upon trying to open the form in the editor.  That is, it took a long time with a couple of different messages telling me to wait, then finished with "I give up".  I think I cleared the cache that time and restarted my PC or something like that to get it to open the form.   I figured it might be that jotform servers were being updated or under heavy usage but the problem seems to have just got worse.

    Apart from this issue there is no sign of any other problem with any other website.

  • Profile Image

    Answered by cheekyface on June 02, 2015 at 09:33 PM

    So I've uninstalled then reinstalled google chrome again from a new download.

    There is no difference but what I have just discovered is that it seems to be the same with other forms of mine too.  Where just the other day they were all working fine, something is causing this to malfunction now.

    My booking form is also now behaving the same way.  The link to the booking form is on the quote form at http://form.jotformpro.com/form/42831279630961?

    I've just checked the form on the other computer and it looks OK there so I suppose that means it has to do with my PC.

    Can you think of anything that would cause this?

    Would it be a google chrome setting or something like that?  

    This is just weird.  I'm pretty sure I don't have a virus or any spyware that could be doing this but I'll run a scan and see if that helps.  In the mean time if you can make any suggestions or if you want to set-up a screenshare please let me know (if that makes it easier).  I have a teamviewer account.

  • Profile Image
    JotForm Support

    Answered by ashwin_d on June 03, 2015 at 12:21 AM

    Hello Danny,

    This is strange. I am not sure why it is not working for you but we are unable to replicate the issue you are having. Your form seems to work fine and I was able to load your form in editor as well.

    Can you also open your form in "incognito" window as well and see if the issue persists. In chrome, you can click on the "Ctrl+Shift+N". You may also like to share a screenshot as well. The following guide should help you upload image in forum post:  http://www.jotform.com/answers/277033 

    Do get back to us if the issue persists and we will report it to our back end team.

    We will wait for your response.

    Thank you!

  • Profile Image

    Answered by cheekyface on June 03, 2015 at 12:51 AM

    incognito version is the same:

    (is someone able to check to see why I'm not receiving a notification from you guys when you reply here?). 
    I mentioned it before regarding both the tech support responses and quote form submissions but the quote form is working now.  I just haven't received any of the replies to this thread.  Not sure again if it's to do with Jotform but for now it appears the only problems I'm having are in one way or another related to jotform.

     

    Screenshot below is of the incognito browser view of the form.

  • Profile Image
    JotForm Support

    Answered by ashwin_d on June 03, 2015 at 04:04 AM

    Hello,

    I'm sorry for the trouble caused to you. 

    Taking a look at the screenshot you have shared, it seems the "Button Checkboxes" widget itself on first page is not being displayed at all.

    Can you please let us know your chrome version number and also which operating system are you using? Have you embedded this form in your web page? Please share the web page URL and we will take a look.

    (is someone able to check to see why I'm not receiving a notification from you guys when you reply here?).

    Please be noted that the forum reply is sent to the account email address. I did check your account email address and it is not in our bounce list. You should be receiving the emails on   info@cheekyface.com.au. I did check our email logs and it seems to be successfully sent. Please check the logs below:

    [2015-06-03 00:18:35] Forum-Reply SENT to info@cheekyface.com.au from noreply@jotform.com via AMAZONSES [2015-06-02 08:53:19] Forum-Reply SENT to info@cheekyface.com.au from noreply@jotform.com via AMAZONSES [2015-06-01 10:22:30] Forum-Reply SENT to info@cheekyface.com.au from noreply@jotform.com via AMAZONSES

    Have you checked your spam folder already? Please check your spam folder and see if the email ended up there. You may also like to speak to your email service provider and ask them to whitelist our domain names as well. The following guide should help you grab the list of domain names :   http://www.jotform.com/help/145-Whitelisting-JotMails-IP-Addresses 

    We will wait for your response.

    Thank you!

  • Profile Image

    Answered by cheekyface on June 03, 2015 at 06:55 AM

    Thanks for all that. The form is the same one I have provided the link to.  I haven't embedded it.  I use a redirect from my website to take people to the form.  So the address: http://cheekyface.com.au/quote will redirect the user to the form at jotform.  

    Chrome Version 43.0.2357.81 m

    As far emails goes, I'm still not recieving them for these comments.  I just check in every so often to see if you have responded.

    About a week ago I started moving my website to another hosting company and my ip address was blocked by that companies server after a few failed attempts using ftp.  I had a few issues with email back then but it's all back to normal now and I can't see it missing in any other areas ...only in relation to jotform.  I've been checking the spam folder frequently and carefully before deleting and there's nothing there from jotform.  I've also logged onto the email server's webmail and checked it there and there no sign of anything recent from jotform except the quote form submissions.

    I'll worry about the email stuff later as it may change when I finalize the move of the website to the new host.

    If you guys are interested in perhaps accessing my PC via a controlled remote session please let me know.  I have had success with tech support from Zoho in the past and they quickly figure out the issue in most cases.  I'd need to be around for it though so we'd need to make an appointment.

    Alternatively I'll keep going as is but if things don't improve soon it'll be a big dissapointment as I'm quite used to working with Chrome however for the sake of jotform forms I'll have to just use firefox until a solution is found.  I've never encountered anything like this before.

    If you can make suggestions otherwise, I'll do what I can at my end and see if that makes a difference - I just think it would be far quicker if one of your tech people just accesses my PC remotely and worked it out for themselves.  At least to assess whether it is in fact my browser or something else.

  • Profile Image
    JotForm Support

    Answered by Boris on June 03, 2015 at 10:05 AM

    I am not sure how much this will help, but I can only replicate your issue if I block access to the following script:

    http://d2g9qbzl5h49rh.cloudfront.net/static/jotform.forms.js?3.2.7317

    (1. Are you able to open this file directly? 2. Does the form load fine after that?)

    Whatever the underlying issue is that is causing this problem for you in Chrome, I can't seem to replicate it in normal use, in none of my browsers. I can only replicate it by deliberately blocking this script, and I would assume that this is not something that your regular users would experience.

    Please let us know how it goes.

  • Profile Image

    Answered by cheekyface on June 07, 2015 at 02:40 AM

    Hi Boris.

    Thanks for that.  I find it a little confusing and not sure where to look for the script except to use the url you provided.  Still I don't know what to do with it and to answer your question "yes", I can access the URL and I see a lot of code but I don't know if that's what you mean.

    NEW information::
    I was content to just use firefox for checking forms after editing until now.  The same thing is now happening in firefox and the only things I've done is add new condition and then refreshed the page where the form is live.  It was upon refreshing it that it went wrong and is now showing exactly the same thing as I see in chrome and behaving the same way.  I cannot go past the first page and it also had hidden the check box as you have depicted above.

    I tried this with explorer as well and when I first go to the form it's fine.  I tried to refresh and it had no affect (the form still seemed OK).   I starting completing the form and then once I'd gone past the first page, I refreshed it then and that's when it turned.  It's now the same in all 3 browsers.

    I don't know what to think now.  It's obviously not a browser issue and I'm even more swayed to the idea that there is something in the form that is causing this.  You guys are the experts - I hope you can help work this out since, as of right now, I can't edit my forms and then test them to see if they are doing what I want.

  • Profile Image
    JotForm Support

    Answered by Mike_G on June 07, 2015 at 09:23 AM

    We would like to apologize for the inconvenience this have caused you. I have tried to replicate the issue, but I have no luck. I would suggest that you try to check your form using a different computer on the same network you're using when you're encountering the issue, you should also try opening your form from a smartphone or a tablet and see if it will work there. Also, I would suggest you try to turn off or disable your antivirus and/or firewall then re-open the browser and load your form. Disabling any extensions and/or add-ons on the browser might also help. I will clear your form's cache so it will be refreshed from our server. 

    You have mentioned that these things happened when you made some changes with the conditions on your form, you can try to check the form's revision history using this guide: How-to-View-Form-Revision-History, to check whether the issue started after the changes you have made or it is really with your browser. I hope this helps. We will wait for you response. Thank you. 

  • Profile Image

    Answered by cheekyface on June 07, 2015 at 10:50 PM

    Hi Mike.

    Thank you for that.

    I just turned off my anti-virus and the form is now working fine.  I have a free download version of bitdefender.  Is there anything you can recommend that I do to keep the anti-virus rather than replace it (yet again) with something else?

    Thanks again!!
    There doesn't seem to be any option to add domains to a white-list or anything where I could get it to allow jotform to be overlooked or allowed.

  • Profile Image
    JotForm Support

    Answered by ashwin_d on June 08, 2015 at 12:54 AM

    Hello Danny,

    I am glad to know that you figured out the issue related to anti virus and your form is working fine now.

    I am not sure about bitdefender, but you can try other free antivirus tools as well:

    Microsoft Security Essentials

    Avast Free antivirus

    Do try out these antivirus program and see if the issue persists.

    Thank you!

  • Profile Image

    Answered by cheekyface on June 09, 2015 at 03:39 AM

    Actually I've just upgraded to the paid version and it seems to be working fine. Hopefully there won't be too many people out there using the free version of bit defender.

    Anyhow, thanks guys for your help and patience with this.