Jotform Designer not displaying all the options and is not saving

  • Profile Image
    rolfes
    Asked on June 04, 2015 at 07:24 AM

    I'm using the Designer to change the look of my form. Only some of the Designer seems to work - I can't open the Form Layout or Font Options sections. When I do change things, such as the background colour, the 'Save' button doesn't work - it just doesn't do anything, so when I close the Designer I get the message 'Discard changes?' to which I have to say 'yes'. This appears to happen on all my forms. I am using Firefox and have cleared the browser cache and the form caches.

    http://www.jotform.com//?formID=42383040149348#design

    Alan

     

  • Profile Image
    Carina
    Answered on June 04, 2015 at 10:22 AM

    Hello Alan

    I tested and could replicate the same situation, both on Firefox and on Chrome:

    But it is not happening with all the forms:

    It does not seem browser related as when I tested your forms I got the same result, but when I tested one of my forms, Designer displayed all the options:

    I will forward this situation to our developers so they can analyse better this situation.

    We'll let you know as soon as we have more details.

    Let us know if we can assist you further.   

  • Profile Image
    rolfes
    Answered on June 04, 2015 at 01:39 PM

    Thanks.

    I look forward to hearing what they say.

    I ought to add that all of these forms used to work perfectly - it's only recently they've been acting like this.

    Alan

     

     

  • Profile Image
    Swoodruff2002
    Answered on June 04, 2015 at 11:02 PM

    I've had very similar experiences today. My forms have lost all CSS formatting, suddenly.  When I tried to restore them from History, they were wiped of styles and themes. Very odd.  

    Would you also address when we should make style changes with designer CSS Helper and when we should use Preferences>Form Styles>CSS Injector?

    Thanks - I hope it will be resolved soon, I'm on a deadline and have to rebuild my complex form, it seems.

    Seve

  • Profile Image
    BJoanna
    Answered on June 05, 2015 at 04:13 AM

    @Swoodruff2002

    I have moved your question to separate thread and we will provide you an answer there shortly.

    http://www.jotform.com/answers/582620 

  • Profile Image
    rolfes
    Answered on June 08, 2015 at 04:58 PM

    Is there any progress on my (original) question? I have tried cloning a form, and the clone behaves exactly as the one from which it was cloned i.e. Designer changes cannot be saved.

    Alan

     

  • Profile Image
    Swoodruff2002
    Answered on June 08, 2015 at 05:03 PM

    Designer is very buggy.  I also noticed the the Designer and the Builder and the Preview are not synched. Sometimes the changes in the designer were not reflected in the builder, and I had to clear browser history and cache to see the changes in Preview.

    Also help to clear Cash in ACCOUNT level of Jot Form, especially if you've been making lots of changes to forms.

    Steve

  • Profile Image
    raul
    Answered on June 08, 2015 at 05:42 PM

    @rolfes

    The ticket has been assigned to a developer and was marked with an important priority.
    As soon as we have any news about this matter we'll notify you here.

    @Swoodruff2002

    Thank you for your feedback. We appreciate you took the time to share your experience with us.
    You'll also be notified here when we have any news about this bug.

  • Profile Image
    hasan
    Answered on June 15, 2015 at 07:58 AM

    Hello Alan,

    We made some improvements about the issue. Could you please try it again and let me know if the problem persist?

    Thank you for your report.

     

    Have a nice day!

  • Profile Image
    rolfes
    Answered on June 15, 2015 at 02:02 PM

    Thanks. This now seems to be working

    Alan

     

  • Profile Image
    BJoanna
    Answered on June 15, 2015 at 02:12 PM

    You're welcome. 

    Feel free to contact us if you have any further question.