Conditional logic - skip to last page

  • Profile Image
    trademarque
    Asked on June 29, 2015 at 02:12 PM

    Hello

    my form has multiple options for people who are subscribing (this is a printed magazine), updating an address or cancelling a subscription. The conditions are working for jumping to a page of fields. That works, but I can't get it to skip pages to the end after this step. It used to work on FormsCentral.



    This is a re-post of a comment on Smart Forms Using Conditional Logic

  • Profile Image
    BJoanna
    Answered on June 29, 2015 at 03:13 PM

    Are you working on this form: <user requested to delete the link to the form>

    I see that you have set conditions on all fields on your first page. Now if I understood you correctly when your user is redirected to e.g. 2nd page and when they fill data on 2nd page you want to redirect them to last page rather than 3rd page. Is that correct?

    To achieve that you need to add more conditions inside of your form. For example you can set that if First Name field on your 2nd page is filled when user click on Next button he will be redirected to last page.  You will have to to that from one of the fields on each page. Considering that names of your fields are same on each page, be careful when you are setting your conditions.

     

    I have cloned your form and added this conditions on my cloned form.

    http://form.jotformpro.com/form/51795552139968? 

    Feel free to clone it if you want to take closer look on my conditions.

    Hope this will help. Let us know if you need further assistance. 

  • Profile Image
    trademarque
    Answered on June 30, 2015 at 02:47 AM

    Thank you very much! This works great, and saved me time. Appreciate the excellent support.

     

    Can you please redact (delete) the links to my forms in this thread?

    Thanks!

  • Profile Image
    Chriistian
    Answered on June 30, 2015 at 07:51 AM

    Hi trademarque,

    On behalf of my colleague, BJoanna, you are welcome. Glad to hear that the problem was solved. I have also deleted the link to your form in this thread as you requested.

     

    Do let us know if you need further assistance.


    Regards.