Submit button not working!

  • Profile Image
    Asked on July 02, 2015 at 12:50 PM

    help! I have a form that I have checked a million and one times to make sure that it works properly. It worked just fine for the first week. No problems. Now all of a sudden when you push the submit button (checkout) the form just stays on the same page & nothing happens. When you click submit (checkout) button you should be redirected to Paypal to finish your check out. But nothing happens. And I'm not sure what happened change to make it stop working.


  • Profile Image
    Answered on July 02, 2015 at 01:33 PM


    I did some testing with a clone of your form and I was able to reproduce your issue.  I narrowed it down to the second terms and conditions widget in your form:

    Try removing that widget and adding a new one back to your form.  There appears to be a bug with the old version of the widget in your form.  You could also replace that text with a single checkbox:

    Replacing the widget with a new copy or removing it all together should allow your form to function properly once again.

    If it does not, let us know and we will be happy to have another look.


  • Profile Image
    Answered on July 02, 2015 at 09:51 PM

    Thanks! That worked. Any idea why it even happened?

    Also, I know I could just use the basic checkbox but the asterisk (required field) would be in a completely different place. It makes the form look sloppy. Is there a way to put the asterisk where I want it to be? I guess that's two questions...
  • Profile Image
    Answered on July 02, 2015 at 11:43 PM

    As mentioned by my colleague, it seems related to an old bug with the said widget. It is also possible that your widget did not update when our developers released the new version of it, that is why re-adding it fixed the problem.

    For the question regarding the asterisk in the required field, I've opened a separate thread for it. Please refer to this link instead: We'll address that one shortly.

    Thank you.

  • Profile Image
    Answered on July 06, 2015 at 07:21 AM

    Thanks again. It's working just fine now.