I have no thumbnail when I post my new pages on facebook

  • Profile Image
    shaunaschollaert
    Asked on July 09, 2015 at 11:02 AM

    I am sharing my form link, not linking it to a profile or page. When I share the link via facebook, only some of them have the thumbnail and some are just blank. What is the secret to getting the image to show as a thumbnail everytime.

  • Profile Image
    Kiran
    Answered on July 09, 2015 at 01:34 PM

    I understand that you are posting direct link of your JotForm in Facebook posts and you notice that the there is getting thumbnail.

    As I tested, I see that the thumbnail appears only when you have an image embedded on your JotForm. If you have all the plain fields on your JotForm, the thumbnail cannot be displayed on your posts. Please see the following screenshots with my tested facebook posts with and without images on the JotForm.

    Without any images embedded on JotForm should be shown as below :

     

    Hope this information helps!! If you are referring to something different, please let us know. We will be happy to help.

  • Profile Image
    shaunaschollaert
    Answered on July 11, 2015 at 11:04 AM

    Yes, I have images on ALL  the pages, they are capture pages.. only some of the images show up when the links are posted...  both of the links you see here are jotform links, both have images in them, only one shows the thumbnail correctly...

     

     

     

  • Profile Image
    Welvin
    Answered on July 11, 2015 at 03:44 PM

    I have posted this form http://www.jotformpro.com/form/51894117141958 to my Facebook Newsfeed/Timeline and Facebook Page Timeline and the image appeared just fine. Here are the screenshots:

    Profile Timeline:

    Newsfeed:

    Facebook Page:

     

    Maybe you have posted the link without waiting for Facebook to parse the image and make it a thumbnail. You should see a loading icon when posting a link, you have to wait until the loading stops.

    Thanks