Sub-user error: "you are not authorized to edit this form" when opening Form Designer

  • Profile Image
    mhunte
    Asked on July 09, 2015 at 02:56 PM

    Hi, My co-worker gave me full access to her forms (and we double checked), but I get an error saying I don't have access to edit the form whenever I try to use Designer, then I can't reload or go back. Do I need a different access level to use Designer?

  • Profile Image
    Sammy
    Answered on July 09, 2015 at 04:11 PM

    You do not need another access level to be able to edit the forms.

    The designer works okay over the http protocol i see that you are on the https from the icon on the right of your address bar. Kindly try accessing it from Firefox as this will give the best perfomance when it comes to editing the form in the mentioned designer.

    Kindly load the designer in Firefox and try to edit a form.

  • Profile Image
    mhunte
    Answered on July 09, 2015 at 04:16 PM

    I didn't understand the part about http protocol, but I tried it in Firefox and got the same error.

     

  • Profile Image
    Kiran
    Answered on July 09, 2015 at 05:39 PM

    I've tried accessing a form from a different account as sub-user and I was able to edit the form normally using Form Designer. I see that your account is provided with full access to edit forms and submissions that are on the other account. Could you try editing a different form from the account? Also, please try creating a new form in their account selecting their respective folder on the left side and then click on Create Form so that the form created in their account.

    Please get back to us with the results so that we take a look at the issue further or forward it to our next level support if necessary.

    Thanks!!

  • Profile Image
    mhunte
    Answered on July 10, 2015 at 10:53 AM

    I just tried to access Designer in a different form on her account and got the same error.

    Do you need her to try to create a new form, or me to try creating a new form? I created a new form under her account, and I can access Designer, but I need to be able to edit her forms that she creates.

  • Profile Image
    Boris
    Answered on July 10, 2015 at 01:10 PM

    I have just logged into your and your colleague's accounts to check, and I have received the same error on Firefox while attempting to edit the form THF Alumni Network Update / Directory - DRAFT:

    I did not get the same error when editing their TEST FORM - the Designer opened fine.

    I've then tried opening the form 2015 Talent Development Program - Membership Form, and received the same error.

    I will forward this thread to our developers, as I could see from your colleagues account that all forms are shared with your account with full rights.

    It might be related that your account is of the sub-user type, rather than a free account type that has been given sub-user rights. Our developers will look into it, and if they can reproduce and fix the issue, we will let you know through this thread. Thank you.

  • Profile Image
    paulsimpson
    Answered on July 19, 2015 at 12:06 PM

    Hi,

    This has now been fixed. Thanks for reporting the problem to us and apologies for any inconvenience caused.