Blank submissions received over API, but these submissions do not appear in the GUI

  • Profile Image
    gugnitzja
    Asked on July 10, 2015 at 09:52 AM

    We have a job set up that pulls submissions via the API and loads them into our Student information system. The last week or so the job has been finding null submissions. These submissions have a submission ID, but all of the fields are null. Also, these submissions do not appear in the GUI, so I can't easily delete them, other than via the API, but I'm not sure why they started showing up at all. An example is included below, but it's happening for several of our forms. Any guidance you can provide is appreciated.

     

    form id -> 40574384580964

    submission id -> 312261958751192491

  • Profile Image
    Boris
    Answered on July 10, 2015 at 12:35 PM

    Thank you for letting us know. I have logged into the account that owns the form to check submissions in the GUI of that particular form, and I could not locate the one with that submission date, nor with that submission ID.

    By using our automated tools, I have been able to fetch that submission and it contained only the submission date and time.

    I have forwarded this thread to our developers so that they can investigate further into what might be happening here. We will let you know via this thread if/when we have any more information regarding this.

    Thank you.

  • Profile Image
    alp_deniz
    Answered on July 10, 2015 at 08:52 PM

    Hello,

    You are so right, we have just made a change and empty submissions are now displayed in submissions page.

    Please let us know if you continue receiving empty submissions. You may like to set some required fields to see whether the forms are actually filled or not.

    All the best.

  • Profile Image
    gugnitzja
    Answered on July 13, 2015 at 09:14 AM

    Thanks for the help. I'll let you know if I have any further issues.