What is JotForm?
JotForm is a free online form builder which helps you create online forms without writing a single line of code. No sign-up required.

At JotForm, we want to make sure that you’re getting the online form builder help that you need. Our friendly customer support team is available 24/7.

We believe that if one user has a question, there could be more users who may have the same question. This is why many of our support forum threads are public and available to be searched and viewed. If you’d like help immediately, feel free to search for a similar question, or submit your question or concern.


  • Profile Image

    Unable to enter data in any field with ID 19

    Asked by rolfes on July 17, 2015 at 07:50 AM

    I've created a form for users to book for a forthcoming event. It seemed to be working, but I've now noticed that for the field "How many children are you bringing?" the user can't enter any data. The field above it ("How many adults ...") is fine.

    I've checked that the field is not read-only, tried duplicating the field, duplicating the 'adult' field and even changing from a 'number' field to a 'text' field, but no luck.

    The form is at http://www.jotform.com//?formID=51815267216354

    PLEASE HELP - people are already trying to book!

    Thanks

    Alan

     

    Page URL:
    http://www.jotform.com//?formID=51815267216354

    text box text area field text field unable to enter data enter data
  • Profile Image
    JotForm Support

    Answered by Jan on July 17, 2015 at 10:22 AM

    I was able to reproduce the issue. The problem is that you are using the "Text Area" element, you should use "Text Box" for this kind of questions. I cloned your form then I replace the "Text Area" to "Text Box" and it is working properly. Here's a screenshot:

    Cloned demo form: http://www.jotformpro.com/form/51974128063962. You can clone it if you like.

    Hope this helps. Thank you.

  • Profile Image

    Answered by rolfes on July 17, 2015 at 10:37 AM

    Thanks for your reply.

    I tried what you suggested and it still doesn't work. Actually I wasn't using either text box or text area for this, but 'number' (from the Quick Tools menu). The 'adults' question just above the 'children' one was created in exactly the same way and it works.

     

  • Profile Image

    Answered by rolfes on July 17, 2015 at 11:39 AM

    I've had to amend the original form as I have people booking. However, the issue can still be seen on a cloned version at http://www.jotform.com//?formID=51974581212355

    Thanks

     

  • Profile Image
    JotForm Support

    Answered by Jan on July 17, 2015 at 12:01 PM

    Can you please check this form? http://www.jotformpro.com/form/51974128063962. As you can see, you can properly enter data on the fields on this form.

    Would it be okay if you clone this form and use it? Here's a guide on how to clone it: http://www.jotform.com/help/42-How-to-Clone-an-Existing-Form-from-a-URL

  • Profile Image

    Answered by rolfes on July 17, 2015 at 12:30 PM

    Thanks for your work on this.

    My problem is that the link has already been sent out to a significant number of people, so I have to use the original form, not a clone.

    I can see that yours works. Why doesn't mine?

    Alan

     

  • Profile Image

    Answered by Ben on July 17, 2015 at 01:44 PM

    I took a look at both of your forms Alan and this is what I can see:

    http://www.jotformeu.com/form/51815267216354

    - It has a number filed on it, and it works as expected - you can not add text, but you can add numbers to it without any issues.

    http://www.jotformeu.com/form/51974581212355

    - It has both fields and both are set equally, but the second field - the one that does not work, is set up as "read only".

    So technically it is working properly - being read only, but since you do not want that option, just click on the field and set it as non read only - that would be it.

    Now since I have checked your settings, I see that it says that it is not read only while being set to not being read only and no matter what I change it is still the same, even after I had removed that field and added the second one with the same label in its place.

    I will look into this a bit further and if needed raise this to our developers as well, but will update you through this thread beforehand.

  • Profile Image

    Answered by Ben on July 17, 2015 at 01:53 PM

    Looking at this a bit further it seems to me Alan that you have had Form Calculation on your form, which had used the field in question. Now the calculation was deleted, but somehow the actual code that was in the calculation was still present, so it was causing this.

    The way to resolve this is to add a new field instead of it, but it must have a different ID.

    Now if you wish, do let us know if this is the form: http://www.jotformeu.com/form/51815267216354 where you need that field and if you want us to place it there for you and we will do that, while in the same time, I am raising this to our developers to find out why and how the form calculation code is still present and doing this issue.

    As soon as the issue is resolved, we will update you through this thread about it.

    - You can see my form here that works: http://form.jotformpro.com/form/51975225789976

  • Profile Image

    Answered by rolfes on July 17, 2015 at 05:25 PM

    Thank you.

    I think we are getting closer to the solution here, but we are not quite there yet. I did try to generate a new 'number' field entirely on the form, with a view to deleting the old non-working one, but the new field I created had exactly the same properties as the non-working one i.e. it showed up on the form but users could not enter data into it. I assume that this new field would have had a different ID to the old one.

    See the added field at http://www.jotform.com//?formID=51974581212355

    As far as the Form Calculation is concerned, I may have added that at some stage in a desperate attempt to get it to work, and then removed it when I found it made no difference.

    Alan

     

  • Profile Image

    Answered by Ben on July 17, 2015 at 07:16 PM

    OK Alan, I have just added the field to your live form so that you can properly capture the values that you need.

    I hope that you will not mind this.

    This is the form I added the field to: http://www.jotformeu.com/form/51815267216354

    I have also made a test submission and it seems to be working properly.

    Now I did not change the test form (clone), so that our developers can take a look at the issue.

    You will see that I had added a text field on your form that is set to be hidden, so that you can add new fields without them being blocked - until our developers resolve the issue.

    Again, I hope that you will not mind me making the change for you, but if you wish, you can simply revert back to any point in time that you prefer by following the steps here: How to View Form Revision History

  • Profile Image

    Answered by rolfes on July 18, 2015 at 04:29 AM

    Ben

    Thank you for this. Yes, that seems to work as it should.

    Alan