What is JotForm?
JotForm is a free online form builder which helps you create online forms without writing a single line of code. No sign-up required.

At JotForm, we want to make sure that you’re getting the online form builder help that you need. Our friendly customer support team is available 24/7.

We believe that if one user has a question, there could be more users who may have the same question. This is why many of our support forum threads are public and available to be searched and viewed. If you’d like help immediately, feel free to search for a similar question, or submit your question or concern.


  • Profile Image

    Links being stripped from field labels

    Asked by dvminfo on July 28, 2015 at 03:22 PM
    Hello,
     
    This is a follow-up to an email exchange we had about not being able to insert hotlinks into a question text. I tried to include .gif screenshot images with the email I sent you through Gmail and you recommended I use this email platform to also include images. 
     
    I had been trying to add the hotlink the way you showed me - the hotlink shows as inserted in the settings window (see the first screen shot below), but as soon as I close it, the hotlink disappears (see 2nd screen shot below). Since I am able to make the hotlinks stay for the text in the check-box options, I don't know why I can't have it stay in the question text. The hotlink doesn't show in the Preview either.

    Another question I have is about the run-over text in the check-box options you can see at the top of the 3rd screen shot below (under the Enrollment Intent Statement header). If I shrink it the option text, it will look the way I want it to, but the question text gets cut off.

    I look forward to hearing from you about how to fix these issues.

    Thank you,
    Violeta

    Violeta Bonneville
    dvminfo@umn.edu

    University of Minnesota

     
     
     
     
     
    screenshots follow hotlink JotForm uploads shrink preview
  • Profile Image
    JotForm Support

    Answered by Mike on July 28, 2015 at 05:01 PM

    Thank you for contacting us.

    Please try adding the link HTML code via field Properties.

    It seems that code is being stripped in editor, but you will see the link on your online form.

    I have attached a bug report ticket about the code stripping issue to this thread.

    To fix the issue from the 3rd screenshot, please set the field 'Label Align' to 'Top'.

    We will let you know if we have any updates.

  • Profile Image

    Answered by dvminfo on July 28, 2015 at 05:24 PM
    Thank you, Mike. I added the HTML code via Properties as you indicated, but
    the code disappeared when I closed the Properties window. I need to add two
    hotlinks in this section. After I added the first one, I noticed it
    appeared in Preview mode. I then added the second hotlink, and in Preview
    mode, I can only see the second hotlink I added, and the first one is gone.
    The alignment part worked well - thank you for answering that question.
    Please let me know if this is due to a bug and when it can be fixed.
    Thank you,
    Violeta
    Violeta Bonneville
    Admissions & Scholarship Coordinator
    Academic and Student Affairs
    College of Veterinary Medicine
    University of Minnesota
    Tel: 612-624-4747
    ...
  • Profile Image
    JotForm Support

    Answered by EltonCris on July 28, 2015 at 07:36 PM

    @Violeta

    This has now been submitted to our developers for a review. You will receive an updates about this via this thread.

    By the way, I can add multiple hyperlinks on the label without any problem. Perhaps, there's something missing on your code. I would suggest to review it.

    Thanks!