Encrypted Form: Email condition with recipient based on a field is not sending

  • Profile Image
    andrewj8
    Asked on August 25, 2015 at 07:53 PM

    I have two emails that should be going out automatically when a user submits the form and they don't seem to be going out now. Not sure what I did wrong.

  • Profile Image
    Chriistian
    Answered on August 26, 2015 at 12:40 AM

    Hi,

     

    I checked your form and I can see you have 2 Notification email and 1 Autoresponder Email. One Notification email is being sent conditionally and also the Autoresponder. See screenshot below.

    When you say two emails, are you referring to the two conditional emails that are being sent upon submit of the form? If so, I noticed that in your Saved Conditions there are deprecated conditions (none existing fields in the conditions) can you try to remove this conditions and see if the conditional email will work?

     

    Do get back to us if the issue still persists or if you are referring to a different concern.

     

    Regards.

  • Profile Image
    andrewj8
    Answered on August 26, 2015 at 05:38 AM

    i deleted all those conditions, and it still doesn't seem to be sending the emails

  • Profile Image
    Chriistian
    Answered on August 26, 2015 at 07:10 AM

    I am currently checking your form. Please give me more time to further investigate the issue. I will get back to you as soon as I get a result.

  • Profile Image
    Chriistian
    Answered on August 26, 2015 at 07:45 AM

    Hi,

     

    As per further investigation, it seems that the email condition with recipient email based on a field is not working on encrypted forms. I will escalate this issue to our development for the to further check the issue. We will inform you on this thread any updates on this issue.

     

    Do let us know if you need further assistance.


    Regards.

  • Profile Image
    andrewj8
    Answered on August 26, 2015 at 09:45 AM
    I turned off encryption and the emails still don't go out
    On Wednesday, August 26, 2015, JotForm Support Forum <
    noreply@jotform.com> wrote:
    ...
  • Profile Image
    Ben
    Answered on August 26, 2015 at 11:28 AM

    I took a look at your form and from what I can see your autoresponder is set as conditional on the required field, to be sent only if it is filled out.

    This means that you do not need to make it conditional - since it is required, they must fill it out, or they would not be able to submit the form.

    If they must fill it out, that means that condition will always be true.

    Based on all that, I would set email autoresponder to be plain autoresponder - without any conditions on it.

    Now it is also good to point out that encrypted forms do not send email notifications nor email autoresponders as regular email do - that is just one of the 'sacrifices' of higher security measures.

    You can read more about this here: What are Encrypted Forms and how to use them as expert?

    Now going onto the second - email notification, it is not working because it is not set up properly. As it is currently set, it will not send the email at all, since it say that it should be sent as a value of some field, which is not email.

    As you can see it is pointing to {pleaseEnter} while the same field's tag is now {optionalPlease}.

    - I presume that you had it without "(optional)" text, which was added later on, but that for some reason it did not get updated. Most likely doe to the files being related to emails, while encrypted forms and emails are not something that you can combine.

    Do let us know how it goes after making the changes I have mentioned above.