Edit link in grid listing ignores the domain name assigned to form.

  • Profile Image
    twhite1969
    Asked on August 26, 2015 at 02:21 PM

    Hi, yesterday I submitted the following thread regarding the new edit url.  

     

    http://www.jotform.com/answers/616870-Add-an-option-on-Grid-Listing-report-to-display-edit-URLs

     

    It appeared that rebooting and clearing my cache temporarily resolved the issue but it is occurring again.  It appears that the problem may be with the form being unsecure.  The edit url works if the link is https but I get the error with a http link.   

    I went into embed form to changed the form to secure and the edit links in the reports will temporarily work but the form quickly reverts back to unsecure without me making any changes. 

     

    Let me know if you want to see screen prints or the report itself.  Thank you very much for your help!

  • Profile Image
    BDAVID
    Answered on August 26, 2015 at 04:18 PM

    I just opened the edit link of one of your form submission, and it opened with any issues:

    I believe that the problem is not with the HTTP protocol, could you share a screenshot of the error you received?

     

  • Profile Image
    twhite1969
    Answered on August 31, 2015 at 01:53 PM

    Hi Here is the error I get when I  click on the edit link. Thanks for your help.

  • Profile Image
    BDAVID
    Answered on August 31, 2015 at 04:20 PM

    The issue is not with the edit links listed in your Grid Listing report: http://www.jotform.com/table/52375749089066

    That error you receive is on regards of the direct link of the form, which is viewed in an incorrect JotForm Domain. We have implemented a domain separation rule. Depending on what country you are in, there will be an assigned separate domain name to you. (i.e. jotform.us, jotform.me). Any forms created will only work on that domain. If you'll attempt to view your forms using different domains, the error above will show up. Clicking the link below should redirect you to the correct form URL.

  • Profile Image
    twhite1969
    Answered on September 01, 2015 at 11:33 AM

    Thanks for your response.

    Clicking on the link brings me to the blank form.  None of the fields are populated.  I have tried this with several of the links and the form is blank each time.

  • Profile Image
    ashwin_d
    Answered on September 01, 2015 at 02:12 PM

    Hello twhite1969,

    I'm sorry for the trouble caused to you.

    I did test the edit links of your grid listing report and I am able to replicate the issue you are having. The issue seems to be related to how the edit links is added in the grid listing report. Please be noted that when a form is created, a domain is assigned automatically but it seems to be ignored when the edit link is added in report and that is the reason why you see the "Invalid Form URL" error message.

    Let me report it to our back end team. We will get back to you as soon as we have any update form them.

    For now, you will have to manually edit your edit link in browser and use jotform.us instead if jotform.com.

    Example;

    http://www.jotform.us/form.php?formID=50715821030140&sid=316330583844659943&mode=edit

    Thank you!

  • Profile Image
    twhite1969
    Answered on September 01, 2015 at 03:45 PM
    Changing the domain to .us works and will be helpful until the issue is corrected. Thanks for your help!

    ...
  • Profile Image
    Shadae
    Answered on September 01, 2015 at 05:53 PM

    Hi twhite1969,

    We are happy to hear that suggestion provided is a suitable alternative until the issue has been resolved.

    Any update on this issue will be posted to this thread.

    Please feel free to contact us if you need further assistance.

  • Profile Image
    alp_deniz
    Answered on September 04, 2015 at 03:11 AM

    Hello,

    Report edit links are now pointed to the correct domains. Thank you very much for your patience.

    Kind regards