What is JotForm?
JotForm is a free online form builder which helps you create online forms without writing a single line of code. No sign-up required.

At JotForm, we want to make sure that you’re getting the online form builder help that you need. Our friendly customer support team is available 24/7.

We believe that if one user has a question, there could be more users who may have the same question. This is why many of our support forum threads are public and available to be searched and viewed. If you’d like help immediately, feel free to search for a similar question, or submit your question or concern.


  • Profile Image

    File upload won't work anymore

    Asked by yousabaoth on September 07, 2015 at 06:29 AM

    File upload stopped working on jotform. The form gives an upload error after submission.

    The form wasn't modified before the error occured and it was working in the past - not long ago.

    Page URL:
    http://www.yousconference.com/registrati/

    Screenshot
    work stopped working file upload
  • Profile Image

    Answered by Ben on September 07, 2015 at 11:19 AM

    Can you please try to remove your Google Drive integration and see if the same issue is still present for you when submitting the form?

    Also based on the settings on the form, file must be under 4MB, while I do believe that it is of correct extension - based on the error above.

    Do let us know how it goes.

  • Profile Image

    Answered by yousabaoth on September 09, 2015 at 04:10 AM

    Hi Ben,

    First of all, thank you for answering.

    I'm quite sure that the problem is not the Google Drive integration because I made that modification as a mitigation for this problem (because I thaught it was a disk space problem, even though I paid for disk space on JotForm servers), but I removed it now and there is no difference.

    I also changed the max file size to 8 MB and even this change didn't work. The form file upload is still not working.

    I tried to create an empty form with the only upload object and it works. I have no idea why it is not working in my form though it was working before and I didn't made any change to break it; users notified me it was broken.

     

    Thank you.

  • Profile Image

    Answered by yousabaoth on September 09, 2015 at 04:24 AM

    I also tried to clone the form, delete the upload object and add a new one but is still not working.

  • Profile Image
    JotForm Support

    Answered by david on September 09, 2015 at 12:04 PM

    I cloned your form to test it and it looks like the form itself is working properly.  I was able to complete several submissions and upload files without issue.  When I tried to submit your form, however, I was unable to complete a submission, though I did not receive an error. 

    I checked your embed code and it looks like there is extra code added that may be interfering.  Your embed code should be:

    <script type="text/javascript" src="//form.jotformpro.com/jsform/51966668000963"></script>

    It is currently:

    <script type="text/javascript" src="//www.jotform.com/jsform/51966668000963?redirect=1"></script>

    Try the form without the redirect on the end to see if that helps.  If it does not, try the iFrame embed code instead:

    http://www.jotform.com/help/148-Getting-the-Form-iFrame-Code

    If neither of those solutions work, let us know and we will be happy to have another look.

  • Profile Image

    Answered by yousabaoth on September 10, 2015 at 03:43 AM

    Thank you David for helping me.

    I will absolutely try to modify the embedded code but before that I would like to make a consideration: the form is not working even standalone.

    I just tried to run a "preview" of the form from the JotForm page "My Forms" and I attach you the result. It seems that there is something not working well in the form itself.

    I have also tried to clone it but for me even the clone doesn't works.

    Thnak you for your precious support.

  • Profile Image

    Answered by Sammy on September 10, 2015 at 08:52 AM

    I tested with a cloned copy of your form and the uploads went through properly on my end.

    I did the same with your form and received the upload error.

    I ran fix on your folders and tested again and was able to submit the data successfully.

    There seemed to be an issue with your upload folder permissions, kindly test your form again and confirm if the upload goes through on your end.

    I have submitted three test submissions with your form, all of which have gone through.

  • Profile Image

    Answered by yousabaoth on September 10, 2015 at 09:36 AM

    I tested the form right now and I confirm that it works.

    Thank you so much.