My purchase order form is not working for my customers!

  • Profile Image
    chapterjewelry
    Asked on September 23, 2015 at 01:58 PM

    My purchase order form -- http://www.jotform.us/form/52627974712160 -- 

     

    is not working for anyone other than me -- clients hae submitted orders where only half the items came through, others don't get a total as they go, others submit orders where nothing gets submitted at all. Please help ASAP. The form was working for me (still is!) but I sent the link to clinets who might be trying to put in orders right now and can't.

  • Profile Image
    chapterjewelry
    Answered on September 23, 2015 at 04:58 PM

    Fixed it myself -- to who ever at jotform is sending test submissions please stop. 

  • Profile Image
    Ben
    Answered on September 23, 2015 at 05:00 PM

    Looking at the form on your page, I can see that you are using iframe embed code with the secure link and the only thing that seems off is that the images are being loaded over HTTP protocol from your form.

    This issue could only cause some of your clients to not be able to see the images on your form due to the browsers blocking insecure content, but most of them will still show the images.

    To fix this, all you would need to do is to change the src attribute of your iframe to point to your form like so: "http://www.jotform.us/form/52627974712160" instead of the https (secure) equivalent.

    For me the only issue that I had noticed was with your api/census with the record hits, where not all seem to come with a reply on your server, causing a small freezing and a big delay while loading the page:

    When I fill out the form and submit it I am taken to the Thank you Page properly:

    Now to mention next to the above. I am now trying to open the page www.chapterjewelry.com/form and it just keeps rotating for me for a very long time even after few refreshes.

    What I would suggest is to check if your server resources are being near their limit, or if there is some error causing the delay and no responses to be made from time to time.

    Also, can you please ask if your users have any issues filling out your form if they go directly to it: http://www.jotform.us/form/52627974712160 ?