Form Submission using Submit Button is not Responsive

  • Profile Image
    djoost
    Asked on September 28, 2015 at 01:11 PM

    Hi there, 

     

    I was working with someone from JotForm support a while back on this issue but that person stopped responding. On the last page of my form when I click "submit" the page flashes another submit button right above it but does not refresh to the confirmation page. If I move fast enough to click the submit button that appeared the form will submit. Any help would be appreciated. 

     

    Thanks,

    Dustin

  • Profile Image
    KadeJM
    Answered on September 28, 2015 at 01:56 PM

    It seems to me that you are having trouble getting your form to submit properly and that you had a similar issue but it was never fully resolved and has come back again.

    I found this thread here https://www.jotform.com/answers/616581-Technical-Issue-with-a-Survey#2 where you had David helping you and he responded to you last but never got a reply back after that so it seems we lost communication with you there if that was the original issue possibly.

     

    Anyhow, I tested this and found your form does appear to be a little slow but I was able to get it to submit. However, I did notice that it took a few clicks before I was able to get the submit to work.

    I think there is something else interfering with this on your form but please allow me some time to investigate the issue further as you have a very long form which may take awhile. We will respond back to you about this problem as soon as we can.

     

  • Profile Image
    StrawberryDesi
    Answered on January 25, 2016 at 12:39 PM

    Hey djoost ,did you every get your problem fixed? I am currently having a problem with my Submit button.  Please let me know.
  • Profile Image
    BJoanna
    Answered on January 25, 2016 at 03:49 PM

    @StrawberryDesi

    I have moved your question to separate thread and we will provide you an answer there shortly.

    http://www.jotform.com/answers/755472